Firmware update V1.1.2 - Experience report

  • I noticed an update to my motion sensors, TShelly is 20210531-091017/v1.1.2@aeceaa55,

    Before it was 1.1.0.

    Also there was update to phone app! I hoping things go well.

    updates to follow

  • Well, I don't have any Cloud enabled devices. So, I manually upgraded my motion sensors.

    Experience is not really excellent.

    1. First, I had to manually reboot the Shelly Motions, so that they would see the update.

    2. Updating took a considerable time, much longer than the usual Shelly devices.

    3. After updating, I was unable to connect to the Shelly Motions, though they did work.

    4. Reset a device is not straight forward anymore. Seems the device notices the reset button is pressed, but when you wait too long to connect to its own generated WiFi signal, it returns to the configured mode. In itself not a bad idea, but I didn't know about it.

    5. Re-configuring the device is a snap, like it was before. Now I see time indicators next to the 'Action' URL entries. Apparently, one can program in that they only detect during a preset time interval. Like :
    from 06:00 to 23:00

    or something similar. Nice, but anyway, I left both to 00:00. I hope that is okay for them to always work.

    6. After configuring, the device goes - without warning - into power saving mode. It's pingable, but the device only answers sometimes.

    So, now I tried to connect to the device to access the web interface. >>impossible<<

    Once the device is set up, the web interface loads a little bit (I tried 4 different browsers: Safari, Chrome, Brave and FireFox). But immediately (I suspect it goes to sleep) the loading is halted - for ever. I suspect the device after a small sleep does not remember I connected to it.

    In short, after the device is set up, it works, but unable to get to the web interface anymore (the actions are done well, though).

    Finally: I'll see if the device keeps sending its actions. I can't see the device status anymore, so I will rely on the actions to let me know it is okay. This is very similar to flood, door and other devices, that to save battery go to sleep. They become unreachable (unless the very short moment an action taakes place).

    Let's hope for the best!

  • Well Darn, I had such high hopes, but I'm having the same issues you are, Only one of the 3 I have is working. I hope they keep trying, It will be a great product if they get the bugs out. Points for trying with the update!

  • Olsche

    Changed the title of the thread from “Firmware update!?” to “Firmware update V1.1.2 - Experience report”.
  • Hello, can you reset devices (5 times short press of the reset button). Then ask for log:
    http://IP/debug/log and send me here.

  • I reset the sensor by holding down reset for 30 secs, On my Android phone, I add the device, it sees it just fine, says it's included.

    Return to main screen and refresh it 4 or 5 times to try and get drop down box to open so I can name it and choose room, Open and close app, screen never drops down. Ok Lets Try again. Reset, Add device, included in wifi, success. return to main screen and try to get drop box to show up by refreshing, Box drops down, I choose light icon in discovered devices drop down, it list everything in my house, I dont see motion sensor. Back out of that to choose different icon in drop down box. But it wont drop down again, no matter how many times I refresh. Try again, RESET sensor. Ok Device included, back to drop down box, Refresh screen, 3 times, drop down box never appears.

    Sometimes I get all the way, assign it a room, choose lights to turn on, but wont turn them on or it will but then never turn's them off again.\

    I have updated, rebooted, router, Phone, firmware, I once had all 3 working, but could not choose "turn off after 10 mins of no motion, The one that works now turns light off after a few mins no matter what I choose it the app. I have reset so many times, so many hrs, trying and trying, Turned to support, the forum,

    I have a Pixel 3a, phone, I know it must be very hard getting things to work with all the different Phones, computers, and the weakest link, The people. ;] Thanks for trying, I really like your products but the universe is eating my lunch on the motion sensors.

  • I have two brand new Shellymotion sensors, arrived today. Configured both for client AP mode and updated both of them to firmware v1.1.2. Next thing I did was enter a user/pass under RESTRICT LOGIN. As soon as I saved, by browser prompted me for a password (normal) but as soon as I entered my credentials and hit return the device seemed to freeze (red light on solid for a couple seconds) then appeared to reboot -- eventually see it cycle through all colors. This happened with both sensors.

    Waited a few seconds for them to reboot, and again, access them with a web browser but before I can even be prompted for credentials the unit reboots again.

    I was able to reset (hold for 10 seconds), reconfig for client AP mode, etc. They're working now, but I don't like not having restricted logins.

    I did downgrade one of the sensors to v1.1.0 and was able to save a user/pass successfully without having the unit go into a reset loop. I then updated that sensor back to v1.1.2 and now it's in a reboot loop.

    1) cycles through green/blue (purple?)/red for a few seconds.

    2) blinks green 2-3 times.

    3) red light on solid for ~5 seconds, then off.

    4) 10-15 second with no indicators, then the cycle.

    Edited 3 times, last by jdwhite ().

  • Do not install v1.1.2! No more connection was possible. Reset-procedure and downgrade had cost me 1Hour....

    Also having issues since 1.1.2, becomes unavailable after 45 mins approx.

    Home Automation :: Force update/downgrade Shelly firmware :: Sequr - looking there, what is the device code for the Shelly Motion Sensor please? Or is there another way to downgrade please?

  • I installed it quite easily. A reboot is needed to report the right version. It looks more responsive, i find much less disconnections from network.
    BTW I did not have so bad problems, since I fixed the ip address, also with prevoius version.

  • Hi everybody,

    I am a newbe here, but I already have 9 Shelly devices since 3 months.

    But I have a issue with motion sensor now with the new Firmware v1.1.2, after 2 days working with the new Firmware, it are completly blocked. The red light is on fixed and I can not reset by presing the buttom during 10s. In fact, when I press during 10s, it stay has the red light on and is not turnning the red light off anymore.

    Do you know how I could reset it in order to do a downgrade or ...?

  • Here again,
    Just to comment, after 4 days whit the Motion Sensor blocked with a red light fixed, this morning, it has been wake up alone doing a reboot cycle itself. It is very strangem, it is working fine like the previous week. I do not understand it.

    Any ideas? because the fiability looks very poors.

  • Hi.

    Recently upgraded my firmware on my shelly motion.

    Used to manage via web interface, I set up a static IP ( and authentication via web which worked fine until the update.

    Now I have updated to 3.12.0 and it won't connect. It lets me login, but then won't load fully or let me change anything.

    I have tried to reset, but it is not resetting.

    I have tried to downgrade using shelly's own, and a local web server with the original FW ( but it won't do it.

    Could you please advise what I can try next?

    Many thanks