Verbindungproblem Shelly 2.5

  • Hey Hey liebe Shelly Freunde,


    voller Freude hab ich am Samstag (also als Ostergeschenk für mich) 4x Shelly 2.5 erhalten. <3<3<3

    Endlich startet mein Smart Home Projekt und ich kann ein wenig "basteln" im Haus.


    3 der 4 Shelly laufen auch einwandfrei... hab auch bereits Routinen angelegt, sodass Alexa auch mein "Mach das Rollo hoch/runter" versteht. Bin echt mega begeistert von den kleinen Dingern.


    Dennoch hab ich einen dabei, der mir leichtest Kopfzerbrechen verursacht. Jetzt zum eigentlichen Thema:


    Habt ihr noch ein Tipp was ich machen soll, wenn ein Shelly 2.5 keine IP vergibt? Ich hab den Shelly jetzt gefühlt 10-mal resettet, habs mir der App versucht ihn einzubinden, und auch direkt. Aber er vergibt dem angemeldeten Gerät keine IP, sodass man erst gar keine Konnektivität aufbauen kann.


    Habt ihr damit Erfahrungen oder Lösungsansätze?


    PS: Bitte keine Fragen bezüglich "Wie hast du es verdrahtet?" 3 meiner 4 Shelly´s funktionieren einwandfrei und sind genauso angeschlossen wie der Störenfried ^^

  • den internen Access Point macht der Shelly aber regulär offen? Also verbinden klappt noch und dann geht etwas schief, wenn du ihn ins Heimnetz hängen willst?

    Alternativ könntest du mal versuchen den Shelly via Notebook / Laptop zu connecten (falls vorhanden).

    Dem könntest du dann vorher eine feste IP zuweisen (192.168.33.2) Dann mit dem Shelly AP-WLAN verbinden shellysw25-xxxxx), anschließend müsstest du via Browser auf die 192.168.33.1 gehen (das ist der Shelly) und die Integration im eigenen WLAN vornehmen..

    Bin mir aktuell unsicher, an welcher Stelle es genau hakelt..

  • Jap... ab und zu seh ich den offenen W-LAN Hotspot vom Shelly. Sobald ich darauf zugreifen möchte sagt mir mein Handy "IP Zuweisung..."

    Mit dem Laptop hab ich es auch bereits probiert, aber da ist es der selbe Fehler.


    Das mit der festen IP hab ich noch nicht getestet! Das werd ich gleich mal machen.


    DANKESCHÖN schonmal für deinen Lösungsansatz.

  • Jap... ab und zu seh ich den offenen W-LAN Hotspot vom Shelly.

    Mhh, das macht mich etwas stutzig .. eigentlich solltest du ihn dauerhaft sehen.. hört sich so an, als wenn der immer wieder neu startet was doch auf ein Verkabelungs-Problem hindeuten könnte.. evtl. eine der Schraubklemmen bei N / L nicht sauber verbunden?

  • Hab den kleinen jetzt wieder deinstalliert und von einem Freund, welcher auch ein paar Shelly 2.5 bestellt hatte, einfach mal einen erhalten.


    Habe den wirklich nur 1 zu 1 getauscht und siehe da, er funktioniert einwandfrei.


    Da muss ich mich wohl an den Support wenden.

    Trotzdem vielen Dank für eure Unterstützung :thumbup::thumbup::thumbup:

  • Ja, man zweifelt immer zu erst an sich selbst. :saint:


    Aber gut das man Freunde hat!!!:thumbup:;)

  • Hallo,
    ich bin neu hier und habe mir 3 mal Shelly 2.5 gekauft. Ich habe diese an meine vorhandenen Rolladenmotoren angeschlossen und somit zum Leben erweckt.
    Die Shelly App brav runtergeladen, angemeldet und eingeloggt. Dann habe ich einen Raum angelegt und wollte meine 3 Shellys als neue Geräte verbinden. "Gerät hinzufügen"

    Ich wähle mein Heim-WiFi Netzwerk aus, gebe mein Heim-Netzwerk Passwort richtig ein und schicke es ab.
    Entweder kommt die (grüne) Meldung: Bereit. Neue Geräte konnten nicht gefunden werden.

    Oder verbinden mit Shelly Switch.... AUFNAHME Übeprüfen der Geräte und dann mit der späteren (roten) Meldung geräte konnten nicht aufgenommen werden!
    Ich hatte dieses mir auch schon auf Youtube angeschaut.
    Das funktioniert aber weder mit meinem Android Gerät noch von meinem IOS IPad.
    Mit der zweiten Methode über den Shelly direkt mit WiFi verbinden und dann die IP Adresse 192.168.33.1 eingeben geht so weit ganz gut. Ich kann auch das Gerät umstellen als Rolladensteuerung! nur wenn ich es mit dem Router verbinden möchte (WIFI MODE-CLIENT), Connect the Shelly device to existing WiFi Network, kommt nur noch die Meldung: The device will try to connect to ......., you can continue operating it at its new adress.
    Dann gehts nicht mehr weiter!
    Was mache ich falsch!? Direkt verbinden tun sie sich ja, nur nicht mit meinem Router!
    Ich wäre für eine Lösung sehr sehr dankbar weil ich hier fast verzweifele.

  • Hast du ggf. mehr als ein VLAN und willst die Shellys in ein anderes Netzwerk einbinden als dein Smartphone?


    Unter Android ist das eigentlich sehr unproblematisch, solange sich dein Smartphone im gleichen Netz befinden, in das du die Shellys hinzufügen willst..

  • Ich habe 2 Heim-Netzwerke. Das eine ist aber die TimeCapsule von Apple und hat einen anderen Namen.
    Um mich mit mit dem Shelly direkt verbinden muss ich ja sowieso doch erst aus meinem Netzwerk raus und quasi in das Shelly WiFi rein um dann mit dem Browser und der IP darauf zu gehen.
    Meintest du oben mit VLAN noch etwas anderes als mein Heimnetzwerk WLAN?

  • Vergibst Du denn eine feste IP Adresse bei der Shelly Registrierung oder verwendest Du die automatische (DHCP)? (und ich nehme an dass Du ein 2,4GHz Netzwerk aktiv hast?)


    Zuverlässiger (auch für später) ist eine feste IP. Wenn der Shelly dann über die von Dir eingetragene IP nicht erreichbar ist, dann funktioniert die Anmeldung in Deinem WLAN nicht und Du kannst da weiter recherchieren (falsches PW, falsche SSID, schwaches Signal, ungültige IP etc etc)


    Was bei mir anfangs öfter vorkam: Meine Mobilgeräte waren auf Auto Connect gestellt, d.h. wenn ich mich mit dem Shelly Hotspot verbunden habe, hat das Mobilgerät nach kurzer Zeit die Verbindung selbstständig wieder auf die vorherige Verbindung geschaltet da der Shelly Hotspot ja keinen Internet Zugriff hat. Das passierte mitten in der Registrierung und hatte auch ab und zu zur Folge dass der Shelly keinen Hotspot mehr aufbaute, aber auch noch nicht in meinem WLAN registriert war. Da half dann nur noch Hard Reset. Seitdem schalte ich Auto Connect immer vorher ab wenn ich Smart Geräte im WLAN registriere.

  • Ich habe 2 Heim-Netzwerke. Das eine ist aber die TimeCapsule von Apple und hat einen anderen Namen.
    Um mich mit mit dem Shelly direkt verbinden muss ich ja sowieso doch erst aus meinem Netzwerk raus und quasi in das Shelly WiFi rein um dann mit dem Browser und der IP darauf zu gehen.
    Meintest du oben mit VLAN noch etwas anderes als mein Heimnetzwerk WLAN?

    Viele möchten ihre Shellys in gekapselten Netzen betreiben, die vom Rest der Infrastruktur (Drucker, Computer, Fernseher..) abgetrennt ist..

    Da gibt es dann häufiger mal ein Problem, weil sich das Telefon, bevor man die Shellys in das gekapselte Netz einfügen kann, zunächst selbst in diesem Netz befinden muss bevor man in der App auf "Add device" gehen kann..

    Das ist zumindest unter Android der Fall, IOS ist ja generell etwas anders (kenne ich aber nicht)..

  • Vergibst Du denn eine feste IP Adresse bei der Shelly Registrierung oder verwendest Du die automatische (DHCP)? (und ich nehme an dass Du ein 2,4GHz Netzwerk aktiv hast?)


    Zuverlässiger (auch für später) ist eine feste IP. Wenn der Shelly dann über die von Dir eingetragene IP nicht erreichbar ist, dann funktioniert die Anmeldung in Deinem WLAN nicht und Du kannst da weiter recherchieren (falsches PW, falsche SSID, schwaches Signal, ungültige IP etc etc)


    Was bei mir anfangs öfter vorkam: Meine Mobilgeräte waren auf Auto Connect gestellt, d.h. wenn ich mich mit dem Shelly Hotspot verbunden habe, hat das Mobilgerät nach kurzer Zeit die Verbindung selbstständig wieder auf die vorherige Verbindung geschaltet da der Shelly Hotspot ja keinen Internet Zugriff hat. Das passierte mitten in der Registrierung und hatte auch ab und zu zur Folge dass der Shelly keinen Hotspot mehr aufbaute, aber auch noch nicht in meinem WLAN registriert war. Da half dann nur noch Hard Reset. Seitdem schalte ich Auto Connect immer vorher ab wenn ich Smart Geräte im WLAN registriere.

    Wie gesagt, ich bin da absoluter Neueinsteiger. 2,4GHz Netz hatte ich auch anfangs gedacht ob vielleicht mein Router auf dem 5GHz funkt aber das war es nicht.
    Zu deinem oberen Punkt hätte ich dann die Frage, wie ich dem Shelly denn eine feste Adresse gebe??
    Auto Connect ist auch ein guter Ansatz, aber ist es auch nicht, da er mich ja nicht rauswirft aus dem Netz.
    Wie schon geschrieben, direkt kann ich die Shellys betreiben eben nur nicht mit meinem Router koppeln. Frit!Box 7490

  • Dann sieh mal in Deine FB unter Heimnetz/Netzwerk/Netzwerkeinstellungen/IPV4-Adressen nach. Dort findest Du den Bereich der automatisch vergeben wird (DHCP, von - bis) Die Adressen außerhalb dieses Bereiches sind fest/statisch. Davon nimmst Du eine (natürlich im gleichen Subnetz), die nicht bereits belegt sein darf. (Siehst Du in der Heimnetz/Netzwerk Übersicht).

  • Willst du die Shellys denn in dein reguläres Netz aufnehmen oder in das Gastnetz der Fritzbox?

    Im Gastnetz gibt es ein paar Besonderheiten, daher die Frage..

    Schon ins Reguläre Heimnetzwerk der Fritzbox. Da habe ich auch meine Sonoff integriert. das war aber Plug and Play.

  • Dann sieh mal in Deine FB unter Heimnetz/Netzwerk/Netzwerkeinstellungen/IPV4-Adressen nach. Dort findest Du den Bereich der automatisch vergeben wird (DHCP, von - bis) Die Adressen außerhalb dieses Bereiches sind fest/statisch. Davon nimmst Du eine (natürlich im gleichen Subnetz), die nicht bereits belegt sein darf. (Siehst Du in der Heimnetz/Netzwerk Übersicht).

    OK, ich habe jetzt schon einmal rausgefunden das die Adressen 192.168.***.20 - 192.168.***.200 automatisch vergeben werden. Belegt sind davon 20;21;22 und noch weitere 15 andere. Also nehme ich jetzt eine freie von diesen nicht vergebenen oder soll ich z.B. dann unter 192.168.***. 20 bzw. über 200 nehmen?
    Und was mache ich dann mit der Adresse? Wie vergebe ich eine dieser Adressen an einen meiner Shellys?

  • Du bleibst unter oder über des DHCP Bereiches 192.168.***.20 - 192.168.***.200


    Wenn Du dann zum Shelly Hotspot verbindest und Deine WLAN Daten eingibst (WiFi Mode Client) ist darunter eine Tick Box "Set static IP". Den Tick setzen und dann die Daten entsprechend eingeben.

    - Die gewählte fesze IP Adresse für den Shelly

    - Die Netzmaske: 255.255.255.0

    - das Gateway (= Deine Router IP 192.168.***.1)


    Dann abspeichern. Zurück in Dein WLAN verbinden und die statische IP des Shelly aufrufen.


    Wenn das dann funktioniert, in der Shelly App oder Cloud (falls der Shelly noch nicht als neues Gerät gefunden wird) im 3 Strich Menü oben rechts auf "Add device by IP" und dort die feste IP des Shelly eingeben.

  • Alles so gemacht. Die DNS ist ja nur optional. Dann SAVE. Es kommt ein grünes PopUp Fenster welches mir bestätigt das "Settings changed" und auf dem Bildschirm wird auch bestätigt das "The device will try to connect to FRITZ!Box 7490 dann die statische Adresse(http:// 192.168.***.201) you ca continue operating it at its new adress.
    Gleichzeitig hat er sich dann auch schon wieder mit meiner FritzBox verbunden.
    Aber wenn ich im Browser die Staische neu vergebende Adresse eingebe findet er dazu kein Gerät! Da ist doch was total faul, oder? Die Webseite ist nicht erreichbar schreibt er nur.