'Device is Offline'

  • They better start looking for a solution. I announce on every automation forum I know NOT to buy these sensors and teel what kind of flop this is.

  • Hi,

    Thank you for the reply.

    I've just uploaded the FW to 2 of my sensors that tend to go offline the most (like twice a day sometimes)

    Let me test for a while and get back to you.


    E.

  • My experience has been quite good. Aside from the fact that I cannot reach the web page on the device, I must admit the devices work (trigger http API signals) well now. I only had a single outtage, and all it needed was to press the reset button a single click.

    I don't know what that reset single push button does, but it seems to have 'bumped' the device to connect to the Wifi again and send http signals again. :)

  • If you can use the Motion in USB-powered mode, the performance is infinitely better. Now it's updating status every few seconds.

  • to anyone with connection problems:


    have you already tried the test version 1.1.3-RC7? (Beta)

    Tried this software update yesterday and my device was working until the early hours of this morning and now dropped offline again.

    Edited once, last by Olsche ().

  • If you can use the Motion in USB-powered mode, the performance is infinitely better. Now it's updating status every few seconds.

    Hi, can you confirm this is the trick to "fix" the offline problem ? Then I will try that. But after all that is not the way it should be.

  • I disagree, as the fix is not viable as per device purpose. It's supposed to work with the internal battery. One can't just start pulling cables everywhere ;)

    • Official Post

    I'm very shure, the problem based on App and/or cloud.


    My 3 motions work fine on firmware 1.1.0. But I don't use app and cloud, i'm using homematic and ioBroker with NodeRed.


    The network setup is possible too as a reason.


    Have a nice weekend.

  • Hello everyone,

    after many attempts, like all of you, I arrived at these solutions:

    the sensor must be set with the browser by recalling the IP address with WIFI connection. The web page works well and the settings are fast. You have to set the WIFI - CLIENT with the static IP and add the gateway otherwise the cloud will not work.

    After these settings, you need to make several attempts with the Shelly app and repeat the same settings if it does not read them by itself. If it takes the sensor back off line, try again after a few minutes. It is not the sensor off line but the app that cannot read it.

    Once also set on the app, the alarm and scenes will work fine.

    Greetings

  • Thanks, that's also my experience, except that once you set a login password (as mentionned above), the whole device grinds to a halt (web interface).


    Also, there's NO notification when the battery goes dangerously low, before the device stops working. Maybe it would be nice if there was an http action 'last thing I do before I die' :D

  • a chiunque abbia problemi di connessione:


    hai già provato la versione di prova 1.1.3-RC7? (Beta)

    where can i find the link to upgrade to this beta version? thank you

  • I have 2 motion sensor and they both went offline this weekend. I try reset them to factory buy they go back to offline after setup

  • I have 2 of these motion sensors. The first one seems ok, but the 2nd one loses connection as described . I tried turning off the 5ghz WiFi on my router, which was the same ssid and password. So far, after 2 days this seems to have cured the WiFi disconnect problem. I am wandering if I should split the 5ghz and away and give it a separate ssid and password.

  • Still loosing connection. Very disappointed with this device. The only solution is a third part controller I guess.

  • Sensor has been ok and not losing connection for 3 days. Today I re enabled 5ghz WiFi. Sensor lost connection almost immediately. Turned off 5ghz, pushed button on sensor. All good again. Next I will try moving 5ghz WiFi to a different SSID. It could be the sensor sees the 5ghz WiFi on the same SSID and password and tries to use it.

    For info, sensor is already on reserved IP.