Can't connect Shelly 1PM to my Wifi

  • I bought Shelly 1PM and Shelly 2.5. While I had no issues connecting the 2.5 to my Wifi network (manual is great and it's also very intuitive), I can't do the same with Shelly 1PM. Whatever I try I can't get it connected to my Wifi.

    - I connect with my phone to the Shelly AP

    - configure Wifi client via the WebUI (192.168.33.1)

    - after a while the Shelly AP disappears

    - the Shelly won't connect to Wifi

    Checking the DHCP leases, no entry. I tried setting up static IP on the Shelly, no luck. Tried to add the Shelly to my Wifi via the Shelly App. No luck either.

    Is there any log or anything I can read why the Shelly can't connect to my Wifi?

  • I am periodically having issues with multiple shelly devices after updating them all to 1.9.0 especially with with my H&T's.


    I had to roll the H&T's back to 1.8.0 since they are part of my climate control and now will be doing the same with my other devices.


    To restore connectivity for a short period of time under 1.9.0 I am having to power cycle the access point and the devices.


    They honor the last command issued to them but drop off of the WiFi connection at some point and then never reconnect.


    Here's the procedure I had to use in order to downgrade the firmware on my H&T's:


    RE: No longer able to join Wi-Fi network

  • Hello


    I am exeprienceing the same issue reported by vlado_nemo: I can connect to Shlly 1PM when using its own WiFi (Shelly-xxxxx), as soon as it is ocnfigured in client mode it desappear and it cannot connect to the local WiFi 2.4GHz.


    The device has a 20190329-09091 firmware that I am not able to upgrade as the Shelly 1PM cannot be connected to interenet.

    How can I troubleshoot this issue? Is there a way to check why the Shelly 1PM is not connecting to the local WiFi.



    Thanks

  • Hi and welcome to the forum. :)


    Your first shelly ?


    Other shellly connected to your WLAN?