Google Assistant: integration working but not activating the switches

  • I've a challenge with Google integration for my first 2 Shellies.


    I installed a Shelly1 and a Shelly 2.5 to control lights, very simple setup - working perfectly from the Shelly app, definitely happy. I did the integration of the accounts, imported the device from Google Home successfully and I can see both


    Now: I see the devices correctly, the status is updated correctly on Google Home every time it changes on the switch (via app or physical button). But actions launched from Google Home simply have no effect: the status on GH changes for a second, but then immediately reverts back to the previous one. No signal is sent to the Shelly - I cannot see anything in the log.


    I tried disconnecting and reconnecting the Shelly account from GH, rebooting the rooter, rebooting the devices, factory resetting - no changes. I tried to change the configuration of the device from Lights to Relay - it disappeared from GH, then changed back to light: I can see and get the status... but still same behavior: does not work. Looks like a cloud-to-cloud issue that I'm not able to control.


    A bit disappointing as a first installation, but maybe I'm missing something very basic....