Shellys nicht einbindbar

  • Hallo an alle hier im Forum,


    ich bin mal gespannt ob das Problem lösbar ist. Seit drei Tagen versuche ich meine gekauften Shellys zu integrieren, leider ohne Erfolg.

    Bisher versuchte Varianten:


    - Einbindung über IOS (Shelly Cloud)

    - Einbindung über Android (Shelly Cloud / Shelly Home)

    - Einbindung über Browser

    - Einbindung über Shelly.Admin

    - Vergabe der IP über DHCP + Statisch

    - Vergabe der Zugangsdaten (SSID / PW sowie Zugangsdaten Account) über alle oben genannten Apps/Programme


    Die Shellys werden jeweils als AP gefunden und können auch zum jeweiligen Device connecten. Danach fangen aber die Probleme an. Es ist nicht möglich die Shellys in meinen Account zu übernehmen. Ich kann zweimal eine Konfiguration über den AP versuchen, jedoch ohne Erfolg. Danach ist der jeweilige Shelly komplett verschwunden und kann auch nicht mehr über 192.168.33.1 oder die fest vergebene IP angesprochen werden. Bevor jetzt fragen kommen wie korrekte SSID usw. eingetragen - JA, hab ich.

    Die Einrichtung wurde mit allen oben aufgeführten Varianten versucht. In der Shelly Cloud App wird mir beispielsweise gesagt, das ein Gerät dem Netzwerk zugefügt wurde, jedoch fehlt die Einblendung der "Discovered Devices". Es ist schlicht kein Gerät in der App zu finden. Auch nicht über Shelly Admin, einfach NICHTS!

    Gestern Nacht habe ich dann abgebrochen und heute Morgen in der Shelly Admin festgestellt, das ein Shelly 1 auffindbar war, den konnte ich auch ansprechen bis zur Vergabe einer festen IP (hab es am vorabend nochmals mit DHCP versucht und so gelassen), GROSSER FEHLER denn der Shelly war darauf hin weg und das wars ...

    Verbunden wird über einen ASUS 68U mit Merlin Software. Im Play Store lese ich bei den Bewertungen zu grossen Teilen ähnliche Probleme, sprich keine neuen Geräte einbindbar, das kann ja kein Zufall sein. Sowohl ein Netzwerkspezi als auch ich haben inzwischen aufgegeben.

  • Wenn Deine Zugangsdaten richtig sind und Dein Router mit anderen Geräten (Handy, Tablet, etc.) keine Probleme hat dann könnte es evtl. an Deinen Zugangsdaten als solchen liegen. Hast Du da evtl. Sonderzeichen mit drin? Es gab glaube ich mal ein Problem das die Shellys nicht alle Zeichen akzeptieren. Bin mir aber nicht sicher ob sich das auf das WLAN-Login bezog.


    Auf jeden Fall ist es das gleiche Fehlerbild das ich auch schonmal hatte als ich mich bei den Login-Daten vertippt hatte. Der Shelly hat alles angenommen und gespeichert und war anschließend auch verschwunden und nicht mehr auffindbar. Nach Reset und Eintragung der richtigen Daten war dann alles gut.

    Grüße Bernd


    Mein "Smarthome":

    FHEM als "Master" (Cloud-Free :)) mit über 30 Shellys (1, 1PM, 2, 2.5, 4Pro, RGBW2, alle mit Original-FW), Sonoff's (mit Tasmota-FW), One-Wire (Temp-Sensoren), Modbus (Hutschienenzähler), Intertechno 433MHz (Rolladen-Aktoren), etc. ...

  • Hallo Guzzi-Charlie,

    alle anderen Geräte inkl. SmartHome laufen (HUE, Alexa, Tablets, Handy, ...).

    Keine Sonderzeichen im PW (extra rausgenommen, hat aber keinen Unterschied gemacht).
    Die Logindaten sowie SSID und PW sind korrekt eingegeben. Spielt die Länge eine Rolle? Kann aber eigentlich auch nicht sein, da ja einer über Nacht den Weg ins Netzwerk gefunden hat. Resetten musten wir schon gefühlte 100 mal ...

  • Sorry, mehr fällt mir leider nicht ein. Bis auf den einen genannten Fehler (meine Schuld) hatte ich noch nie Probleme mit dem Einbinden ins Netzwerk. Ich verwende eine Fritzbox 7490 und arbeite bisher auch noch ohne feste IP-Adressen.

    Grüße Bernd


    Mein "Smarthome":

    FHEM als "Master" (Cloud-Free :)) mit über 30 Shellys (1, 1PM, 2, 2.5, 4Pro, RGBW2, alle mit Original-FW), Sonoff's (mit Tasmota-FW), One-Wire (Temp-Sensoren), Modbus (Hutschienenzähler), Intertechno 433MHz (Rolladen-Aktoren), etc. ...

  • Hast du mal die andere App (Shelly Home) probiert? Was machen die Shellys dort?


    normal:

    Shelly zurücksetzen,

    App neu installieren,

    in der App Shelly suchen, wenn Wlanabfrage kommt dein Heimnetzwerk wählen inkl. Passwort und schon sollte es klappen.


    hab nun 13 Shellys so eingebunden, bis dato keine Probleme. komisch.

    VG Maik



    Meine Shellys:


    in Betrieb: 11x Shelly 2.5 "Rollo", 2x Shelly 1 V3 "Tor"

    in Planung 1x Shelly Flood, 1x Shelly Button, 2x Shelly 1 V3


    alles ohne Cloud mit gutem Grund. :-)


    Ich übernehme keine Haftung für Fehler. Nur eine Elektrofachkraft darf z.B. elektrische Anlagen und Betriebsmittel errichten, ändern und in Stand halten!

  • Hi


    Probleme mit der WLAN Reichweite?

    Vllt. mal zum Test die Shellys näher zum Router bringen.


    Kannst du andere "neue" WLAN Geräte anmelden? Nicht dass dein DHCP Pool voll ist.


    andere Idee wäre mal noch das 5 Ghz WLAN temp. zu deaktivieren.

    Ich hatte mit meinem WLAN fähigen Mährobotor auch einen Tag gekämpft, bis ich herausfand, dass ein aktive 5Ghz WLAN Probleme bei der Einbindung bereitet.


    Vielleicht hilft es ja

  • "Neue Geräte im WLAN-Netzwerk zulassen" aktiviert?


    Abgesehen von dem Einen der sich reingemogelt hat, noch eine Idee!


    Dieses Problem hatte ich am Anfang meiner Shelly-Einbindung, hatte immer vergessen diese Option zu aktivieren. Nach der Einstellung im AP-Modus war der Shelly weg. Bin fast verrückt geworden.

    Wie haben sie es gefunden? Durch Zufall! ;):D

    Beste Grüße

    Axel

    Theorie ist wenn man alles weiß und nichts funktioniert. Praxis ist wenn alles funktioniert und keiner weiß warum.


    Einsteigertipps / Tips for beginners


    Homematic/IP mit CCU3, iOBroker, Shelly (1, 2.5, RGBW2, PlugS, EM), Arduino (Mega 2560, W5100)->Homeduino

    Visualisierung (auf iPad Air) mit Mediola AIO CREATOR NEO


    Ich übernehme keine Haftung für eventuelle Schäden die aufgrund von Fehlern oder Missinterpretation meiner hier gegebenen Antworten aufgetreten sind oder auftreten werden.

  • :P

    VG Maik



    Meine Shellys:


    in Betrieb: 11x Shelly 2.5 "Rollo", 2x Shelly 1 V3 "Tor"

    in Planung 1x Shelly Flood, 1x Shelly Button, 2x Shelly 1 V3


    alles ohne Cloud mit gutem Grund. :-)


    Ich übernehme keine Haftung für Fehler. Nur eine Elektrofachkraft darf z.B. elektrische Anlagen und Betriebsmittel errichten, ändern und in Stand halten!

  • Was ich bei einem Shelly 2.5 am Anfang hatte war, dass der Taster auf der Rückseite beim Einbau gedrückt wurde, Dauerhaft. Aber das wird nicht dein Problem sein..bei allen Shellys...

    VG Maik



    Meine Shellys:


    in Betrieb: 11x Shelly 2.5 "Rollo", 2x Shelly 1 V3 "Tor"

    in Planung 1x Shelly Flood, 1x Shelly Button, 2x Shelly 1 V3


    alles ohne Cloud mit gutem Grund. :-)


    Ich übernehme keine Haftung für Fehler. Nur eine Elektrofachkraft darf z.B. elektrische Anlagen und Betriebsmittel errichten, ändern und in Stand halten!

  • Dein Netzwerk Spezi konnte nicht helfen? Mir scheint als sind die Daten falsch. Häng doch mal einen shelly an ein Flash Kabel und baue eine serielle Verbindung dahin auf. Dann solltest du in der Konsole (putty oder so) genau sehen woran es hapert. Hab leider alle in der wand aktuell sonst würde ich mal ein Bildchen Posten.


    Ich selber betreibe aktuell ein Netgear Orbi System. Dieses sendet um optimal zu übertragen mit 2.4 und 5 GHz. Hatte nie probleme beim einbinden, wegen der Frequenzen. Auch das beide gleich heißen (ssid) ist egal.


    Würde das ja zu gerne mal live sehen, dein Problem.

  • Dieser Forum setzt ja allem die Krone auf ...

    ... im positiven Sinn. Ich habe noch nie nach so kurzer Zeit von so vielen Mitgliedern Antworten erhalten. RESPEKT :thumbup:

    Der Fehler ist identifiziert. Da hier neben meinem Firmen-Netzwerk noch ein "privates" mit anderem IP-Pool läuft ist folgendes passiert:

    Es sind mehrere Router im Einsatz und auf zwei war Wlan aktiv mit gleicher SSID und PW jedoch eben die unterschiedlichen IP-Pools. Es gab mal ein Abrauchen des alten "Privat-Routers" deswegen musste als Überbrückung damals der "Firmen-Router" konfiguriert werden. Nach Tausch des defekten Routers wurde das Firmen-Wlan wieder deaktiviert. Soweit, so gut nur dass sich durch den Umbau unbemerkt nach Sicherung raus/rein das Wlan des Firmen-Routers wieder eingeschaltet hat. Die Shellys sind bei der Einrichtung also warscheinlich zwischen den beiden IP-Pools geswitcht mal über den einen Router mal über den anderen, eventuell auch das Gerät zum Einrichten, da ja zwischen AP und Wlan gewechselt wird.

    Fazit: Einbinden geht wunderbar, nur habe ich jetzt ein kleines Problem am Switch-Eingang eines Shellys. An diesem Shelly liegt nur ein Taster an, welcher jedoch mit Dimmfunktion ist. Kann es sein das hier der Shelly nicht anspricht? Die Phasen sind korrekt verschaltet, Belegung:

    N = Null
    L = Dauerphase

    SW = geschaltete Phase von Dimm-Taster kommend

    I = Phase von Dauerphase abgezweigt

    O = Phase zur Lampe


    Ein defekt des Relais und Eingang SW im Shelly kann ausgeschlossen werden, da das Relais schaltet und und bei gebrückter Phase auf SW auch geschaltet wird. Nur eben wenn ich es über den Dimm-Taster von Feller schalte passiert nix (Dimmer ist auf max). Der Dimmer ist aber auch OK.

  • Ganz doofe Frage: sind deine IoT-Geräte (Shellys) in einem eigenen VLAN?

    Quote

    Es ist schlicht kein Gerät in der App zu finden. Auch nicht über Shelly Admin, einfach NICHTS!

    Das spricht nämlich eindeutig dafür, dass das Discovery (UDP Broadcasts, die werden nicht geroutet) fehlschlägt..

    Richtiger Weg wäre dann:
    - Smartphone in das IoT-VLAN hängen

    - dann in der App gerät hinzufügen

    - den Shelly-AP auswählen und die IoT-WLAN-Daten eingeben


    Danach wechselt das Smartphone hoffentlich zurück in das IoT-VLAN, dann dauert es zwischen 30-60 Sekunden und es sollten "Discovered devices" auftauchen..


    Edit: ok, dann lag ich ja mit den unterschiedlichen WLANs nicht ganz daneben.. hatte den Beitrag geschrieben, wurde unterbrochen, dann abgeschickt. Zwischenzeitlich hast du den Fehler ja schon selbst gefunden.

  • Hallo Gizzmo_77,

    leider funktioniert der Shelly im Zusammenhang mit Feller Dimmern nicht.

    Die Feller Dimmer haben eine Glimmlampe, im Stecker der die Sicherung hält, integriert.

    Ich habe am vergangenen Wochenende versucht ohne Glimmlampe, aber es hat trotzdem nicht funktioniert, also habe ich die Feller Dimmer ausgebaut und durch Schalter ersetzt.

    Ich beabsichtige einen Versuch mit dem neu erscheinenden Shelly Dimmer zu machen, der kostet sowieso nur ein Bruchteil von den Feller Dimmern.

  • Hallo gizzmo_77 , willkommen im Forum :)

    Dieser Forum setzt ja allem die Krone auf ...

    ... im positiven Sinn. Ich habe noch nie nach so kurzer Zeit von so vielen Mitgliedern Antworten erhalten. RESPEKT :thumbup:

    ....

    Vielen Dank für' s Lob. :thumbup:


    Viel Spass und Erfolg hier.

    LG / best regards

    Stefan

    Ich übernehme keine Haftung für von mir gegebene Antworten, Tipps und veröffentlichte Projekte! Jeder ist für sich selbst verantwortlich! Arbeiten an 230V sind in Deutschland von einer Elektrofachkraft auszuführen!


    Einsteigertipps / Tips for beginners

    Sammlung von HTTP-Befehlen


    Mein System / my system:

    Homematic CCU2 + Charly (CCU3) mit Fremdkopplungen:
    u. A. 3x Shelly 1, 4x Shelly 2.5, 1x Shelly Bulb, 2x Shelly Flood, 1x Shelly H&T, 5x Shelly Plug S und 1x Shelly RGBW2




  • Nein, lediglich in meinem "privaten" Netzwerk.

    Die Shellys haben sich bis auf einen einfach in den falschen Router mit den eigentlich richtigen Daten verbunden. Also:

    "Firmen-Netzwerk" =192.168.x.x

    "Privat-Netzwerk" =192.168.xx.x

    Wlan SSID und PW von beiden Netzwerken identisch und aktiv (Erklärung warum oben)

    Bei Einrichtung per App wird die AP-Verbindung auf- und wieder abgebaut. Die App bekommt die Daten des Shellys. Da die Shellys näher am Firmen-Router verbaut sind, jedoch für den Privat Router konfiguriert waren und ich dort vor Ort die Anmeldung vorgenommen habe, lagen die 192.168.xx.x Shellys auf dem 192.168.x.x Router. Somit stimmte weder IP noch Gateway die über den AP / Browser voreingestellt wurde. Dem Handy solte das per DHCP egal sein, da es so oder so Internet bekommt egal über welchen Router, sprich auch Verbindung zum Account hat. Jedoch kann er die zuvor über AP angesprochenen Shellys durch den Verbleib auf dem falschen Router nicht mehr finden. Das würde auch die Meldung der App erklären, neue Geräte ins Netzwerk aufgenommen zu haben (was ja schon stimmt indirekt) ohne Sichtbarkeit der "Discovered Devices" ...

  • Hallo utschu,

    danke für deine Antwort. Das habe ich mir gedacht. Die Feller Dimmer die hier verbaut wurden haben mich eh schon des öfteren genervt. Standard-Variante verbaut, nix mit LED sprich flackern ohne Ende wegen der zu geringen Last und kosten ein haufen Geld (200,- Euro für einen bei uns in der Schweiz, ich bräuchte vier, da kann ich auch gleich mein Hue System ausbauen ;)). Es kommt doch auch noch eine Dimmer Version des Shellys oder?


    66er Danke für die Begrüssung ...:)


    Edit: hat utschu ja schon oben geschrieben mit den "erscheinenden" Dimmern. Gibt es da schon ein Datum ab wann es die gibt?

  • Dieser Forum setzt ja allem die Krone auf ...

    ... im positiven Sinn. Ich habe noch nie nach so kurzer Zeit von so vielen Mitgliedern Antworten erhalten. RESPEKT :thumbup:

    Vielen Dank! :thumbup:


    Und ... WILLKOMMEN im Forum! :) Habe ich heute irgendwie verdaddelt! X/



    Gibt es da schon ein Datum ab wann es die gibt?

    Nein, ein Datum ist noch nicht raus. Aber plane mal jetzt ab Pre-order einen Monat locker ein!

    Beste Grüße

    Axel

    Theorie ist wenn man alles weiß und nichts funktioniert. Praxis ist wenn alles funktioniert und keiner weiß warum.


    Einsteigertipps / Tips for beginners


    Homematic/IP mit CCU3, iOBroker, Shelly (1, 2.5, RGBW2, PlugS, EM), Arduino (Mega 2560, W5100)->Homeduino

    Visualisierung (auf iPad Air) mit Mediola AIO CREATOR NEO


    Ich übernehme keine Haftung für eventuelle Schäden die aufgrund von Fehlern oder Missinterpretation meiner hier gegebenen Antworten aufgetreten sind oder auftreten werden.