Shelly 1PM gets hot

  • Got two Shelly 1PM, flashed with tasmota, calibrated on 60W bulb, everything works.


    Week ago attached one to air conditioner which uses 1500W (7A):

    when off shelly temperature is 50-60c at 25c room temp

    when on shelly temperature gets to 75c after an hour and then heating cycle ends so shelly cools

    seems bit high but as long as it gets to 75c max I’m ok with it.

    cc.PNG


    Now attached one to water heater which uses 2600W (12A):

    when off shelly temperature is 50-60c at 25c room temp

    when on shelly temperature gets to 90c after 20 minutes and turns off by itself.

    aa.PNG


    I’m using them only for monitoring power consumption not for controlling devices.


    Wired them both according to shelly instruction like this:

    a.PNG


    What could it be source heating problem? 12A should be ok on 16A switch

    Edited once, last by potat0 ().

  • potat0

    Changed the title of the thread from “Shelly 1PM gets hot, wiring options?” to “Shelly 1PM gets hot”.
  • seems bit high but as long as it gets to 75c max I’m ok with it.

    Don't worry, 75 degree Celsius is the internal temperature (MCU) which is absolutely ok ..


    Shelly1PM automatically turns off if a critical temperature is reached (which is IIRC around 95 degree celsius)

    when off shelly temperature is 50-60c at 25c room temp

    when on shelly temperature gets to 90c after 20 minutes and turns off by itself.

    this is the self protection mentioned above.. the issue is probably related to the place where the Shelly is installed.. a closed box? then there is no air circulation which increases the temperature over the time..


    Maybe you can install inside a bigger box or with some distance to other devices, which may affect the temperature?

    10x Shelly1, 7x Shelly 1PM, 2xShelly 1L, 9x Shelly 2.5, 3x Shelly2, 1x Shelly EM, 2x ShellyDimmer, 3x ShellyDimmer2, 1x Shelly 3EM, 1x Shelly4Pro, 1x Shelly Button1, 4x Shelly Duo, 1x, ShellyDuo G10, 3x ShellyVintage, 1x Shelly Bulb, 8x ShellyDuoG10RGB, 1x ShellyPlug, 2x ShellyRGBW2, 5x Shelly PlugS. 1x Shelly Sense, 3x Shelly i3, 1x Shelly Gas, 4x Shelly H&T, 1x Shelly Flood, 2x ShellyDoor&Window2, 3x TempAddon, 1x ShellyMotion

    Edited once, last by Seven of Nine ().

  • Don't worry, 75 degree Celsius is the internal temperature (MCU) which is absolutely ok ..


    Shelly1PM automatically turns off if a critical temperature is reached (which is IIRC around 95 degree celsius)

    this is the self protection mentioned above.. the issue is probably related to the place where the Shelly is installed.. a closed box? then there is no air circulation which increases the temperature over the time..


    Maybe you can install inside a bigger box or with some distance to other devices, which may affect the temperature?

    Yes it's in very tight and closed box and there is no possibility for better place


    These devices supposed to be in such places I think, and still it's only 12A from 16A


    Maybe tasmota firmware has something to do with it, later I'll reflash them and try with original firmware


    From your signature you have tons of Shellys, did you try one of them under load of more than 10A for long period of time, at least an hour?

  • From your signature you have tons of Shellys, did you try one of them under load of more than 10A for long period of time, at least an hour

    not a 1PM, I use those only for lights.. ShellyPlug for my washing machine, Shelly EM for the Dryer, Shelly4Pro for the oven and fridge.


    Maybe tasmota firmware has something to do with it, later I'll reflash them and try with original firmware

    yes, you should definitely test with the stock firmware ..

    10x Shelly1, 7x Shelly 1PM, 2xShelly 1L, 9x Shelly 2.5, 3x Shelly2, 1x Shelly EM, 2x ShellyDimmer, 3x ShellyDimmer2, 1x Shelly 3EM, 1x Shelly4Pro, 1x Shelly Button1, 4x Shelly Duo, 1x, ShellyDuo G10, 3x ShellyVintage, 1x Shelly Bulb, 8x ShellyDuoG10RGB, 1x ShellyPlug, 2x ShellyRGBW2, 5x Shelly PlugS. 1x Shelly Sense, 3x Shelly i3, 1x Shelly Gas, 4x Shelly H&T, 1x Shelly Flood, 2x ShellyDoor&Window2, 3x TempAddon, 1x ShellyMotion

  • My 1PM on stock firmware running a 3kW immersion heater in a closed box approaches 85°C reported temperature after half an hour or so, at which time the immersion heater turns itself off: the Shelly doesn't trip itself.


    I doubt this is firmware-related: it's probably just the combination of the I²R heating of the power measurement circuit and the ventilation situation.