Problem with button1

  • Hello, I ordered before Christmas shelly button1 and got information that my order will be delayed because factory flash wrong firmware on this device and I must wait for new flash. Finally i received it but i think something is wrong with my device and firmware. First of all: firmware version that is shown on web server: 20201210-145729/?@47dcf392/ It does not show version but only '?'. Second: I can't add this device to android app and home assistant. When I try add it to android app by discovery or manually by ip address I received information that application lost connection with device. I rebooted it, reverted it to factory settings etc. but no luck. Shelly integration for HomeAssistant don't show device either. Button is powered by usb all the time. Of course i try without usb power but with not luck. Can somebody help me?:?:

  • ghostek

    Set the Label from Shelly Button to Shelly Button 1
  • Same problem here too with 20201029-170348/v1.9.0@85c87178.


    Eventually got it added to the iOS app by IP address after dozens of attempts, but only with cloud disabled. Setting a static IP through the web interface seemed to help.

    Can enable cloud through the web interface but doesn't update in the app or seem to actually do anything besides the icon colour in the web interface.


    Says it's on battery even when on USB and battery removed.

    Says no firmware updates are available but should be able to get 1.9.3.

    Time display remains at "--:--".


    Got the device added to Home Assistant using ShellyForHASS but don't get any usable entities or events related to button pushes. Only battery level, RSSI, cloud status..


    Also tried manually upgrading and downgrading from internet and local sources using links like

    http://10.0.99.157/ota?url=htt…loud/firmware/SHBTN-1.zip


    Something very broken in the firmware.


    Have emailed support. Will let you know if they get back to me with anything.

  • Eventually got is added to the app with cloud enabled after multiple attempts. Had to use a phone hotspot and tablet. Once added to the app I then changed the wifi settings to my normal network.


    Time still reads as "--:--", but cloud is connected.


    Still cant get any click events or button/switch status in Home Assistant using ShellyForHASS. Looks like I'll be using MQTT for that.

  • Eventually got is added to the app with cloud enabled after multiple attempts. Had to use a phone hotspot and tablet. Once added to the app I then changed the wifi settings to my normal network.


    Time still reads as "--:--", but cloud is connected.


    Still cant get any click events or button/switch status in Home Assistant using ShellyForHASS. Looks like I'll be using MQTT for that.

    Same here. Two brandnew button 1 and no chance to connect them to the cloud.


    VERY frustrating! In the parcel were also Plug S. They worked like expected.


    Plug S: 1.9.3

    Button 1: 1.9.0 (no update offered)


    Please keep us informed 👍

  • I already contacted with support. Send them even movies. And they always respond same time. Try to update ota, try to connect with app. I serverd http server and when try to force ota, shelly button did not make request. You can replace address with anything always same respond from button. For me = broken firmware.