Instabil - Shelly immer wieder nicht erreichbar

  • Hallo zusammen,


    Ich bin gerade am Testen meiner geplanten Installation und da nehme ich meine Shelly 2.5 immer wieder mal vom Strom, aber bei jedem 2. / 3. Mal ist sie dann nicht mehr erreichbar, nur ein Reset über den Button mit neuerlichem Einrichten im AP-Modus löst das Problem wieder bis zum nächsten AusfallX(. In der Cloud war und ist sie nicht.


    Wobei es 2 Arten von "nicht erreichbar" gibt:

    1. kompletter Ausfall, bucht sich nicht mehr ins WLAN ein (sehe ich am Access Point, keine DHCP Requests). LED blinkt. Nur ein Reset hilft hier weiter, aber auch nicht auf Anhieb, musste das auch schon drei Mal wiederholen, bis es endlich ging.

    2. Ausfall der Weboberfläche, aber noch per ICMP/Ping erreichbar (im WLAN eingebucht). LED konstant. Reboot hilft dann nach der x-ten Wiederholung.


    Mein WLAN würde ich als Fehlerquelle unverdächtig ansehen, alle anderen Geräte laufen problemlos, auch esp8266 Boards.


    So kann ich das Teil nicht in die Elektroinstallation einbauen.


    Ist das ein Problem in der Firmware oder ein Hardwaredefekt?

  • unverbindlich und ohne konkrete Idee warum:

    Auf die schnelle, habe ich es nicht wieder gefunden, aber, ich bin mir relativ sicher, dass ich es gelesen habe:

    Die Stabilität hat sich bei einem Benutzer mit AP's deutlich erhöht, wenn er den AP als Gateway eingetragen hatte.

  • ich werd

    unverbindlich und ohne konkrete Idee warum:

    Auf die schnelle, habe ich es nicht wieder gefunden, aber, ich bin mir relativ sicher, dass ich es gelesen habe:

    Die Stabilität hat sich bei einem Benutzer mit AP's deutlich erhöht, wenn er den AP als Gateway eingetragen hatte.

    Kann ich mir nur dann vorstellen, wenn das ein Bug im Netzwerkstack der Firmware ist. Ich kann auch deswegen nicht meine komplette Nertzwerkarchitktur umbauen.


    Ich hab die Shelly vor 9 Stunden neu gestartet, anfangs ging das Webinterface, mittlerweile ist es nicht mehr erreichbar, nur ping geht noch.


    Das ist echt kein Zustand.:cursing:

  • supernova1963


    so ähnlich 😉


    Beim Einrichten als Client habe ich die kuriose Erfahrung gemacht, bei Gateway nicht die Router-IP sondern die Repeater-IP eintragen, dass die Verbindung stabil ist.


    Ich finde meinen Beitrag auf die Schnelle auch nicht 😉🤣

    Beste Grüße

    Axel

    Theorie ist wenn man alles weiß und nichts funktioniert. Praxis ist wenn alles funktioniert und keiner weiß warum.


    Homematic/IP mit CCU3, iOBroker, Shelly (1, 2.5, RGBW2, PlugS, EM), Arduino (Mega 2560, W5100)->Homeduino

    Visualisierung (auf iPad Air) mit Mediola AIO CREATOR NEO


    Ich übernehme keine Haftung für eventuelle Schäden die aufgrund von Fehlern oder Missinterpretation meiner hier gegebenen Antworten aufgetreten sind oder auftreten werden.

  • mal ganz abgesehen davon, dass DHCP beim allerersten Einrichten ging und dann nicht mehr: was verstehst Du unter "Repeater-IP"?


    Was meinst Du: Bug in der Firmware oder doch ein Hardwaredefekt? Ich bilde mir ein, dass das anfangs nicht so war, zumindest ist es mir nicht aufgefallen.

  • was verstehst Du unter "Repeater-IP"?

    :/ ??? :/


    Ein Repeater erweitert bekanntlich das heimische WLAN-Netz und hat im Netz natürlich ebenfalls wie alle Geräte eine IP.

    Diese wird dann im Feld GATEWAY eingetragen.

    Beste Grüße

    Axel

    Theorie ist wenn man alles weiß und nichts funktioniert. Praxis ist wenn alles funktioniert und keiner weiß warum.


    Homematic/IP mit CCU3, iOBroker, Shelly (1, 2.5, RGBW2, PlugS, EM), Arduino (Mega 2560, W5100)->Homeduino

    Visualisierung (auf iPad Air) mit Mediola AIO CREATOR NEO


    Ich übernehme keine Haftung für eventuelle Schäden die aufgrund von Fehlern oder Missinterpretation meiner hier gegebenen Antworten aufgetreten sind oder auftreten werden.

  • ....

    Diese wird dann im Feld GATEWAY eingetragen.

    Was aber nicht geht, wenn fichtennadel unbedingt bei DHCP bleiben will. ;)


    Und somit erstmal hallo fichtennadel .


    Leider kombinierst du mehrere Faktoren, die sich, laut Erfahrung anderer User und auch mir, negativ auf die zuverlässige (schnelle) Erreichbarkeit nach Neustart auswirken:


    • Eine feste IP-Vergabe im Shelly ist aus der Erfahrung aller resultierend funktional deutlich besser als DHCP. (Auch ich habe inzwischen allen meinen Shelly feste IPs vergeben)
    • Aus der festen IP folgt dann der Rat von SparkyMaster , bei Verwendung von Repeatern, deren Adresse als Gateway im Shelly einzutragen (sofern er in dessen Bereich liegt.)

    ... Ich kann auch deswegen nicht meine komplette Nertzwerkarchitktur umbauen.


    Ich verstehe Dein Problem nicht. Gerade wenn Du doch eine geordnete Ńetzwerkstruktur hast, sollte es doch kein Problem darstellen, einen IP-Adress-Bereich für Shellys zu reservieren. Dieser muß halt nur außerhalb der DHCP-Range liegen. ;)


    Viel Erfolg, so oder so. :)

    LG / best regards

    Stefan

    Ich übernehme keine Haftung für von mir gegebene Antworten, Tipps und veröffentlichte Projekte! Jeder ist für sich selbst verantwortlich! Arbeiten an 230V sind in Deutschland von einer Elektrofachkraft auszuführen!


    Mein System / my system:

    Homematic CCU2 + Homematic Charly (CCU3) mit Fremdkopplungen:
    unter Anderen 3x Shelly 1, 4x Shelly 2.5, 1x Shelly Bulb, 5x Shelly Plug S, 1x Shelly RGBW2 und 1x Shelly H&T im Produktivbetrieb.


  • Danke für die Rückmeldungen, Repeater habe ich keine im WLAN (nur einen Access Point) und feste IP auch schon an der Shelly vergeben, da DHCP (nur bei Shelly ...) unzuverlässig ist.


    Das Problem besteht weiterhin bei Neustarts, da ist es ein Glückspiel, wie oft ich resetten und zwischen AP- und Client-Mode wechseln muss, bis die Shelly im WLAN ist.


    Wenn sie mal eingebucht ist, geht's halbwegs, aber das Problem mit dem Webseiten Zugriff tritt immer wieder auf.


    Wenig zufriedenstellend derzeit.

  • ..., Repeater habe ich keine im WLAN (nur einen Access Point) und feste IP auch schon an der Shelly vergeben,..

    1 Accesspoint (ausschließlich)?


    oder


    1 Accesspoint und WLAN am Router?

    LG / best regards

    Stefan

    Ich übernehme keine Haftung für von mir gegebene Antworten, Tipps und veröffentlichte Projekte! Jeder ist für sich selbst verantwortlich! Arbeiten an 230V sind in Deutschland von einer Elektrofachkraft auszuführen!


    Mein System / my system:

    Homematic CCU2 + Homematic Charly (CCU3) mit Fremdkopplungen:
    unter Anderen 3x Shelly 1, 4x Shelly 2.5, 1x Shelly Bulb, 5x Shelly Plug S, 1x Shelly RGBW2 und 1x Shelly H&T im Produktivbetrieb.


  • Und als Gateway hast Du im Shelly die IP des Accesspoints oder des Routers eingetragen?

    LG / best regards

    Stefan

    Ich übernehme keine Haftung für von mir gegebene Antworten, Tipps und veröffentlichte Projekte! Jeder ist für sich selbst verantwortlich! Arbeiten an 230V sind in Deutschland von einer Elektrofachkraft auszuführen!


    Mein System / my system:

    Homematic CCU2 + Homematic Charly (CCU3) mit Fremdkopplungen:
    unter Anderen 3x Shelly 1, 4x Shelly 2.5, 1x Shelly Bulb, 5x Shelly Plug S, 1x Shelly RGBW2 und 1x Shelly H&T im Produktivbetrieb.


  • Und als Gateway hast Du im Shelly die IP des Accesspoints oder des Routers eingetragen?

    Des Routers, wie bei allen anderen Geräten im LAN und alles andere ergibt ja auch kein Sinn: das Gateway definiert ja den ersten Schritt der IP Route aus dem Subnet.


    Was soll aber das Gateway mit der Erreichbarkeit im LAN/Subnet zu tun haben? Oder ist der IP Stack der Firmware so dermaßen buggy?

  • Welchen Access point benutzt du?

    Ich betreibe mein Netz genauso. Router ohne WLAN, dahinter ein Accespoint von Dlink.

    Ich trage bei meinen Shellys auch bei Gateway IP vom Router ein. Bei mir funktioniert aber alles ohne Ausfälle. Evtl ist im AP was nicht richtig eingestellt bei dir?

    LG Michael 😁

    Meine Shellys:

    In Betrieb: 5x Shelly 1 V2, 1x Shelly 1 V3, 2x Shelly 1PM, 2x Shelly 2.5, 2x Shelly RGBW2, 1x Shelly 4Pro, 4x Shelly H&T, 1x Shelly Sense, 9x Shelly Plug S, 1x Shelly Plug, 3x Shelly Smoke V1, 1x Shelly EM, 1x Shelly Eye

    Im Bestellprozess/nicht verbaut: 1x Shelly Plug S, 2x Shelly 2.5, 1x Shelly 2. 1x Shelly 1 V1

    Kein übergeordnete System. Nur App und WebUI 😉 mit Cloudverbindung.

  • Welchen Access point benutzt du?

    Ich betreibe mein Netz genauso. Router ohne WLAN, dahinter ein Accespoint von Dlink.

    Ich trage bei meinen Shellys auch bei Gateway IP vom Router ein. Bei mir funktioniert aber alles ohne Ausfälle. Evtl ist im AP was nicht richtig eingestellt bei dir?

    Unifi.

    Ich hab 10 Geräte im WLAN, alle laufen problemlos bis auf eines ... Shelly2.5


    Es macht auch einen Unterschied, ob ich einen Reboot über das API mache oder sie kurz vom Strom nehme: Reboot ist kein Problem, Strom aus/an aber schon.

  • Hast du mehrere Shellys / Shelly 2.5 im Betrieb? Oder nur den einen?

    Ein defekt ist natürlich nicht auszuschließen.


    Bei mir laufen mittlerweile 32 Shellys. Die kann ich Stromlos machen, soviel ich will. Sie buchen sich trotzdem immer wieder korrekt ein. Egal welcher.

    LG Michael 😁

    Meine Shellys:

    In Betrieb: 5x Shelly 1 V2, 1x Shelly 1 V3, 2x Shelly 1PM, 2x Shelly 2.5, 2x Shelly RGBW2, 1x Shelly 4Pro, 4x Shelly H&T, 1x Shelly Sense, 9x Shelly Plug S, 1x Shelly Plug, 3x Shelly Smoke V1, 1x Shelly EM, 1x Shelly Eye

    Im Bestellprozess/nicht verbaut: 1x Shelly Plug S, 2x Shelly 2.5, 1x Shelly 2. 1x Shelly 1 V1

    Kein übergeordnete System. Nur App und WebUI 😉 mit Cloudverbindung.

  • ...

    Was soll aber das Gateway mit der Erreichbarkeit im LAN/Subnet zu tun haben? Oder ist der IP Stack der Firmware so dermaßen buggy?

    Einfach nochmal lesen, was SparkyMaster dazu geschrieben hat. ;)


    Wie bei MIHO funktioniert es auch bei mir mit der eingetragenen Router-Adresse als Gateway.


    Aus Interesse habe ich temporär damals den Tipp von SparkyMaster getestet und auch das hat funktioniert. Ein Versuch wäre es vielleicht wert!?:/


    Ansonsten tippe ich auch das Zusammenspiel mit Deinem Accesspoint. Ich habe gerade ein ähnliches Problem mit meinen Sonos, die nach einem AP-Wechsel (mit gleichen Einstellungen) nicht mehr richtig wollen. Nutze ich den Alten geht alles wieder. || Und ja, der Rest meiner Netzwerkteilnehmer spielt auch mit meinem neuen AP ohne Probleme.


    Never say never. ;)

    LG / best regards

    Stefan

    Ich übernehme keine Haftung für von mir gegebene Antworten, Tipps und veröffentlichte Projekte! Jeder ist für sich selbst verantwortlich! Arbeiten an 230V sind in Deutschland von einer Elektrofachkraft auszuführen!


    Mein System / my system:

    Homematic CCU2 + Homematic Charly (CCU3) mit Fremdkopplungen:
    unter Anderen 3x Shelly 1, 4x Shelly 2.5, 1x Shelly Bulb, 5x Shelly Plug S, 1x Shelly RGBW2 und 1x Shelly H&T im Produktivbetrieb.


  • ...

    Bei mir laufen mittlerweile 32 Shellys. Die kann ich Stromlos machen, soviel ich will. Sie buchen sich trotzdem immer wieder korrekt ein. Egal welcher.

    :thumbup: Kann ich mit meinen derzeit 16 aktiven Shelly bestätigen.


    Wenn es nur der 1 seiner Sammlung ist :


    ...

    Ein defekt ist natürlich nicht auszuschließen.

    ...

    :thumbup:

    LG / best regards

    Stefan

    Ich übernehme keine Haftung für von mir gegebene Antworten, Tipps und veröffentlichte Projekte! Jeder ist für sich selbst verantwortlich! Arbeiten an 230V sind in Deutschland von einer Elektrofachkraft auszuführen!


    Mein System / my system:

    Homematic CCU2 + Homematic Charly (CCU3) mit Fremdkopplungen:
    unter Anderen 3x Shelly 1, 4x Shelly 2.5, 1x Shelly Bulb, 5x Shelly Plug S, 1x Shelly RGBW2 und 1x Shelly H&T im Produktivbetrieb.


  • Ich tippe mittlerweile auch auf ein HW Problem. Das ist meine erste Shelly, ich hab zum Vergleich jetzt eine weitere bestellt, mal sehen ...

    Berichte mal wenn er da ist. Würde mich schon interessieren.

    LG Michael 😁

    Meine Shellys:

    In Betrieb: 5x Shelly 1 V2, 1x Shelly 1 V3, 2x Shelly 1PM, 2x Shelly 2.5, 2x Shelly RGBW2, 1x Shelly 4Pro, 4x Shelly H&T, 1x Shelly Sense, 9x Shelly Plug S, 1x Shelly Plug, 3x Shelly Smoke V1, 1x Shelly EM, 1x Shelly Eye

    Im Bestellprozess/nicht verbaut: 1x Shelly Plug S, 2x Shelly 2.5, 1x Shelly 2. 1x Shelly 1 V1

    Kein übergeordnete System. Nur App und WebUI 😉 mit Cloudverbindung.

  • So, nach nur knapp 22h Betrieb hat das Ding von selbst den Kontakt zum WLAN verloren, Entfernung zum AP knapp 2m, freie Sicht.


    Ich hab's schon 3x aus- und wieder eingesteckt, dabei kam sie 1x kurz für 46s online, danach nicht mehr.


    Ich hab' keine Lust mehr, morgen geht das Ding zurück.