Shelly 2.5 unable to connect

  • I'm having the same issue, everytime there is a powerloss... I even set wifi channel to static in case this helps... but no luck..

    Last time took shelly 1 day to re-connect to wifi.. now 2 days an still i'm unable to use it...... and due to the location i put it is not practical to hard reset it.

    (though this is not an actual solution ..we have a smart device that we cannot use it)

  • Hello,


    I have a Shelly 2.5 on my roller shutter and it worked fine until the latest firmware update. Now it has lost connection and I can’t get it to find the network anymore (every other wifi appliance in my house works just fine). The device is offline and I would like to know how to fix this problem. Thank you in advance!


    DC6B83F5-AC25-443F-A9C6-75572DC8E864_autoscaled.png

    Hi, difficult to to say what caused devices to go offline, but I have many 2.5s as shutters running on latest firmware 20200827 v1.8.3. with no issues. There are many reasons for offline issues, often due to weak signals or devices like repeaters kicking out, etc.

    Here’s what to do if you want to start from scratch:

    1) delete the device in the APP

    2) turn the fuse giving the Shelly power off and then on again

    3) reset the 2.5 by switching the shutter switch on/off 5 times (you’ll hear the Shelly Relais click on 5th switch) - check in the App if it’s online again

    4) look for the 2.5 on your WLAN list and connect to it

    5) go into you browser WEBUI and type in 192.168.33.1; you should see the Shelly

    6) give it a static IP address outside DHCP router range 192.168.178.xy

    7) connect to router WLAN again, the start Shelly app (discovered devices should come up)

    8) add by IP if discovered devices doesn’t show

  • I tried to figure out what causing the issue, but without any luck.

    Initial configuration was with static IP but still every time shelly was powered off, when power restored was not connecting to wlan.

    I change it to dynamic IP, i added dhcp entry for shelly, i change wlan to static channel, i disable smart connect from router (in order to have seperate 2.4g and 5g ssid's) nothing is working. And to be honest, its is not a solution to factory reset the device each time it fails to connect !!!!!!

    I have a TP-Link Archer C6 to manage my devices... i guess i will try to add it to old router to check if there is any incompatibility issues. though to do that, shelly must decide to connect.

    I'm extremely disappointed with Shelly... not stable at all !!!!!!!!

  • Sorry to hear you still have problems. I'm using a Fritzbox so no experience with your TP-Link Archer router. Again, please confirm you have reset the 2.5 successfully by switching the fuse powering the Shelly on an off and have used Rollo Switch to reset. You must hear the Relais clicks!

  • i'm using it as a "router" managing all connections and using my ISP router as gateway. I have also other smart devices (plugs) and none having this issue.. .only shelly.


    About resetting, i placed shelly on lighting fixture, so its not that easy to reset it every time there is a powerloss. The reason i buy it, was that from my wall switch only one cable goes to light fixture (if i close the switch no power going to Shelly). My light has two lines so i used shelly to turn on each light line separately.


    I will try to reset it and connect it to my ISP router.. if i still have the same issues, i will go for another company to resolve the issue.

    Please also note that there arent any logs to my router, so the device is not even trying to connect ..and some days later..it decides to connect.

  • About resetting, i placed shelly on lighting fixture, so its not that easy to reset it every time there is a powerloss. The reason i buy it, was that from my wall switch only one cable goes to light fixture (if i close the switch no power going to Shelly). My light has two lines so i used shelly to turn on each light line separately.

    Sorry again to hear about your problems. I would like to help, but I really don’t understand your statement above. Maybe you could explain again the wiring or provide a sketch. The Shelly should always have power!

  • Have you activated the user/password access? I had the same problem, after disabling the protected access it works. I am not have with that, but now it works.

    Connect via browser and the IP of your Shelly if it is connected to your router, than you can change the access.

  • I have the same problem. I recently bought a 2.5 shelly to turn on my LED outdoor lamps (3 lamps: 1 for 1 lamp and the other one for the 2 other lamps).


    I can turn the light on and off via the app. But after a few hours it doesn't work anymore and I no longer have a connection. I turn the fuse on and off of the lights and shelly and then it works again for a while.

    I also bought a shelly 1L which does the lighting for outside and that gives no problem at all.


    What to do?

    I have a static IP address for the shelly's.

  • I have the same problem with the 2.5. It disconnects after half a day, I can't reach the webinterface of the shelly anymore and the only way is toggling the mainpower and it will reconnect again.


    I also have 2 Shelly 1's and they don't have this problem.

  • Hi,

    I already put a reply in an other topic for the shelly 1, but now that I found this one I'll also reply here...

    Shelly 1 topic: SHELLY 1 CONNECTION PROBLEMS


    I'm having the same issues. My shelly 2.5 is unreachable after some hours/days, but I can still see it when I look at the list of wifi clients in my unifi-controller. Except that the shelly does not have an ip address.

    The physical buttons still work.


    When I use a static ip address it's no longer loosing it's address... at least with firmware 1.8.3 or 1.8.5.

    Sadly this trick does not work with firmware 1.9.2.


    Shelly config: Roller Shutter, MQTT.

    Router: opnsense

    AP: 2x Ubiquiti HDnano


    So for now I downgraded to the 1.8.5 firmware, but it would be nice if this issue could be fixed.


    I have a lot of Sonoff s20 with espurna and they all work flawless.

  • My 12x 2.5s are all working fine, also on the latest firmware.

    However, if the Wifi RSSI is higher than -60dBm (haven’t measured exactly) it gets critical. I lost one recently after temporarily removing its repeater and had to screw the damn thing from the wall to get it going again, since 5x switch press on power-on didn’t work. My shelly1s survive on -80dBm without going offline. Lesson-learnt, 2.5 need a good signal strength.

  • After allot of testing...

    Issue seems to be caused from my TP-link router.

    If i disable and enable wifi from the router, shelly re-connects.

    Too bad since i bought this router for smart home devices :(

    *excact same issue appeared once with TP-Link P100 plug ..


    I changed wifi to the old crappy ISP router and never disconnected again.


    I'm guessing some incompatibility but i couldn't find anything on the router or shelly logs

  • Finally i found the issue.. It was not shelly related (though shelly was probably more sensitive to that)... Issue was caused from my range extender... i remove it and 3 days now shelly works fine...


    Probably was connecting to the extender and could not change wifi automatically (mesh network)

  • I am having the same issue with my 2.5 being offline, and once I deleted my device, I now cannot get the app to find the device.

    Go via webUI, type in the static address you gave the device (192.168.178.xx). If it doesn’t connect, check your WLAN settings. If you see the 2.5 there, choose it as WLAN and go to webUI with 192.168.33.1 and set the device up again. Give it a name. Then go to app and it should show up. Make sure signal strength is good, if not use repeater and confirm static address in the webUI. This will ensure connection to repeater.

  • I have the same trouble since one month and I try everything reboot my router restart my devices nothing solve the problem actually it’s physically work and respond but when I try to enter the app it show me it’s offline when I check the Wi-Fi it’s doesn’t exist there I try to restart it many time without Anything Mike WLAN work with 2.5 GHz so I don’t know what is exactly wrong I Set ID address for my device and it’s also won’t work

  • It seems that i also have nearly the same error.


    1x Shelly 2.5 for left roller shutter

    1x Shelly 2.5 for right roller shutter


    The right one is still connected and controlable.

    The left one is powered on but not connected. The left roller shutter is still controlable with the switch (left down, right up switch)


    I can only find the right shelly in my Router GUI.


    My goal is to reset the left faulty shelly and add it new.



    How do i do that? The reset button seems covered by plastic. (The U shape)


    Like i said above, i have a switch with 2 switches...

    left down (down/stop)

    right (up/stop).


    Anything i was missing?