Suddenly strange/wrong behaviour Dimmer

  • Hello ppl,


    I'am glad to found this forum because i cant figure the following out, and hope someone have some advice.

    For 2 weeks i had the Shelly Dimmer 2 working flawlessy for my stairway lamp, build-in with L and N wire, and controlled with 2 switches (2 point down and upstairs), in combination with my home automation.

    The Shelly is upstairs at the end of the upstairs switch, between the switch and the lamp (switch to sw1, O to the lamp)

    I have a 10Watt 3x LED lamp, and have put a dimmer bypass in for smooth dimming. (no flickering)


    But last weekend my fysical switches suddenly didnt work anymore, and while figuring this out, i saw that there was a new firmware (1.8.5)

    After applying this firmware, it only got worse. My switches still doesnt work, but also the following.


    With the previous firmware (dimmer2-zc-debounce.zip) i used leading edge dimming, what worked the best and better then trailing edge with my lights. I was able to dim very low to almost dark, and to perfect up like the same it was without dimmer.

    But now when i use leading edge, the dimmer temperature goes very quick above 80 degrees, while before the temperature never got above 50 degrees. (was always between 45 and 49,5 degree)

    Only when i use trailing edge now, the temperature stays between 47 and 53 degrees, but then the low is less low then before, and the max up is also not the real maximum like with leading edge. (i experienced this also in the previous firmware)


    Inside the Shelly web-gui (i dont use the app/cloud) now the leading edge callibration brakes at 60%, while in the former firmware this was going ok. The trailing edge callibration works good to 100%.

    But in the web-gui and with trailing edge, still at 30% the web-gui shows 0 Watt, while the lamp is working good and gives light.

    At 100% the web-gui shows 7 Watt, while the lamp is in real 10 Watt.

    In the previous firmware with leading edge the web-gui showed this correct (30% 3 Watt, 100% 10Watt), but trailing edge had also some of this issue in the previous firmware (100% 8 Watt)


    I tried many hours everything in the settings but no change.

    And back to factory settings or previous firmware didnt work eather. Even some settings in previous firmware where not saveable anymore. (like anti flickering debounce)


    It works ok for now with trailing edge, but not as perfect (with working switches and perfect dimming) like a few days ago.

    If anyone have a clue or some advice, i be glad to hear it.


    ps.

    Can somebody confirm that the status wire_mode: 1 is ok with L & N connected?


    Thnx..



    .

    Edited 11 times, last by Marchutt ().

  • Marchutt

    Changed the title of the thread from “Suddenly strange/wrong behauvoir Dimmer 2” to “Suddenly strange/wrong behaviour Dimmer”.
  • Well.. it seems to be solved :-)

    I had a suspicion that the upstair switch was faulty, and caused the suddenly instability.

    I have changed the switch with a new one and everyting works good now.

    And also showing the good Wattage again in WebUI...

    Edited 3 times, last by Marchutt ().

  • Can´t help with your issue, but it seems to be solved anyway.


    I just wanted to confirm the temperature behaviour respectively the temperature difference between leading edge and trailing edge. With leading edge and about 120W of LED retrofit bulbs I get alarming 105 degrees after some minutes. With trailing edge dimming the temp tops out at 60 deg.


    Also, I´m only able to change these settings and perform calibration via the web interface. No success with the app so far.

  • SparkyMaster

    Set the Label from Shelly Dimmer to Shelly I3
  • Is there a way to see the temperature from the dimmer without taking it out of the wall and measuring it by hand? I can't find the temperature displayed in the webui.


    Also, shouldn't theoretically trailing edge always be the one you should use for leds? I thought they never work correctly with leading edge?

  • Type in browser

    Code
    x.x.x.x/status

    x.x.x.x = ip of your shelly