Shelly 1 connection problems

  • I have 8 shellys 1 connected to control lamps. It systematically loses the connection (device is disconnected). I have to disconnect the power and reconnect.

    It has the latest firmware version.

    The wifi is very good.

    What's up with this? Can you help?

  • It seems that Shelly does not want to give or has no solution for this.

    More people have reported this in other forums.

    If Shelly doesn't answer or solve the problems we have to switch to other products and classify it as bad assistance from Shelly.

  • I have the same problem for about 2 months ... I have gone crazy combining configurations ... mqtt ... coap ... change router, and nothing. I would say that these problems come from the firmware update in March. I have 5 shellys1 and 5 shellys2.5 and they randomly disconnect and don't reconnect to the wifi.

    I hope Allterco can fix this problem as it seems to be widespread.

  • Hello,


    I am also experiencing this problem. My Shellys are disconnecting from the network with no option going back. They (randomly not all at the same time) just disappear from HomeAssistant and when it happens they are also NOT accessible via their native Shelly's WebGUI, but... they can be turned on-off by a wall switch. It means that their Wifi module is hanging after some time.


    First... I was already talking to some HA plugin developers (suspecting plugins) but it appears it's purely Shelly firmware issue - no other wifi device (I have about 5 others mostly Sonoffs running under Tasmota they are always OK - never had any issue like that).


    Later I started discussions with official Shelly support (raising a ticket on their page). I provided many pieces of evidence asking what I can do for them to provide some information useful to fix it. They did not use it at all... Moreover, after a month of talking (mostly me providing descriptions of conditions, suggestions etc.) they just CLOSED my ticket claiming that... it will be "handed over to firmware developers". Now after firmware upgrade to ver 1.7.0 my Shelly went offline again. Nothing was fixed. It's driving me nuts. I consider it a big shame for this nicely designed device.


    Now, I'm considering developing Home Assistant automation that will trigger all Shelly reboot in the middle of the night - maybe reboots will help (I'll post an update here) but is it a really a solution? The firmware or device has an obvious bug!


    I wonder if anybody else having these problems - can you please describe your conditions so we could share the experiences. I never used a Shelly-cloud, I had always enabled local MQTT control. I was also trying at least two HA plugins to control my Shellies - ShellyForHass (utilizing CoAP) and ShellyDiscovery (utilizing MQTT). In both cases, I had always enabled MQTT (even if ShellyForHASS is not requiring MQTT). Is it possible that this is related to MQTT implementation in firmware (this was suggested by one of HA plugin developers)? If you have such an issue, please provide information - are you using MQTT or have MQTT enabled? If you are not using MQTT and experience such problems can you describe your conditions?


    If developers cannot help I hope the community can be a power to solve it...

    Edited 3 times, last by eses ().

  • I do not have mqtt enabled and have the same issue with all shelly, 1, 1 PM and EM, they get randomly disconnected and at different moments.

  • I do have the same issue with one of my Shelly 1PM. Sometimes it works for days without issues. Somethimes it disconnects many times a day. Configured without Cloud, without MQTT. Updates to 1.8.3 firmware. Would be also glad to get a solution!

  • I am having the same problem with a shelly 1pm. FW 1.8.3

    It disappears from my network every couple days, most of the time just after I perform a switch action.

    I have to unplug it, plug in again and it comes back right away.

  • I have had my Shelly1 connected as a garage door opener for a few days, but tonight it disconnected. Of course I was getting the "unavailable" every so often in Home Assistant, but only for 5 seconds at a time. I wasn't worried because HA said it would be fixed in the .118 update on November 18th. Too late and dark to go check it out now (detached garage). I will try to unplug and replug tomorrow. I had it as default "ON" and did an off-on toggle to activate the door, but earlier today (maybe 6 hours before it lost connection) I made an automation to switch off after activation. I doubt this has anything to do with it - just mentioning it to be complete. Both my Shell 2.5s stay off most of the day with no permanent disconnect (just the "unavailable" for 5 seconds) a few dozen times

    Also - to be complete - I can't connect with the Shelly app OR the IP address. Not surprising if I have the same problem as the others here

  • Same problem on my Shelly 1 offline and not contactable untill power is cycled. Have reset reconfigured ect ect. I only have one Shelly ATM and was planning on doing the whole house but this fault means I will use other products. my sonoff devices are rock solid Shelly need to sort this out ASAP

  • Same behavior here. My Shelly 1 (acting as a garage door switch) turned off itself completely last night and i had to take it from the power supply to reboot it. The other problem was, that it has opened my garage door over night. The power on default mode is set to "Off". Within the Home Assistant Log, the Shelly Sensor is displayed as "not available" every 10-15 minutes. ?

  • Hi Guys.


    Same situation here. My 2 shelly 1's have just disappeared after a couple of weeks being installed. They were like yoyo's according to Home Assistant as they kept saying turned off or unavailable and I also read that this was fixed in 0.118 but I would definitely say its not as I dont believe the issue was Home Assistant now as they are offline and say they cant get the time and time out.

    I cant easily get to the Shellys as they are behind lights and dont have a switch as such as they are powered by a fused spur and wired accordingly for the virtual switch and no physical switch.


    I did think about putting on ESPHome.... has anyone tried that ?


    Thanks Martyn

  • Same problem here. One 1PM and another EM looses the connection after some weeks. It is horrible when the devices are installed behind a wall switch and definitely THE reason that currently prevents me from using more shelly devices.

  • Hi,

    I'm having the same issues. My shelly 2.5 is unreachable after some hours/days, but I can still see it when I look at the list of wifi clients in my unifi-controller. Except that the shelly does not have an ip address.


    When I give the shelly 2.5 a static ip address it's no longer loosing it's address... at least for my shelly 2.5 with firmware 1.8.3 or 1.8.5.

    Sadly this trick does not work with firmware 1.9.2.


    Shelly config highlights: Roller Shutter, MQTT so no cloud!:)

  • Hello,

    I have now about 15 Shellies in total (Shelly 1, Shelly 2.5 and Shelly Dimmer 2) with firmware v1.9.0 and DO NOT have the disconnect problems reported in this thread. I also have other 12 SONOFF devices (Basic, TH16, 4CH, 4CHpro, RFbridge and ZBbridge) all running stable and with the Tasmota firmware.


    In the past I did have sporadic DISCONNECT problems with the SONOFFs (Shellies were not installed yet, came later). It required several different attempts until I was able to solve the problem. The solution for me was to:


    - improve WiFi coverage by deploying Wifi repeaters (cheap, about 20EUR)
    - assigning permanent IP addresses on the FritzBox

    - implementing a simple Tasmota rule that triggered an automatic overnight reboot on every SONOFF at 4am

    I hope this hints help some of you. Unfortunately I don't know if such automatic reboot can be implemeted in the Shelly firmware. The REST API provides a facility to trigger a reboot from the home automation, but this feature is useless when connectivity is lost.

    By the way, I would be interested in automatically READING the RSSI (Wifi signal strengh) of the Shellies from the home automation system (Openhab) so that I can detect devices with a weak signal. I know REST API provides this information ( ip_addr/status/wifi_sta) but would prefer an MQTT based solution. IS THIS POSSIBLE?

  • Thank you for sharing your findings. And I agree that a weak wifi signal could cause problems but the distance between the shelly and my access point is about 5 meters and in the same room, so I'm not going to install repeaters.


    However... I did notice that the wifi signal is pretty weak(-75 dBm). Maybe it's time for a different antenna :/

  • Hey there,


    I had first installed a Shelly to test: worked great. Later I installed another 11, put them all on HomeKit firmware. Then the connection issues started, just as described here. Every time I wanted to switch on/off a few lights a random 50% of the shellies was not connected. Mostly also not reachable over IP. I have been using them with static IPs from the beginning. With the shellies in the WiFi network, in fact other WiFi issues started and the internet started being unstable for connected users.


    I then put a FRITZ!box between the crap Telefonica fiber router and all WiFi users. This made them 99% reliable immediately. They are all always available now, BUT: if my WiFi goes for a moment, the router or one of the (also Fritz) repeaters, and a Shelly therefore loses a connection, the Shelly doesn’t reconnect. That sucks big time. I don’t have to reset the shelly, but I need to pull the electricity to force it to reconnect, hence either flip a fuse or open the wall. So I do the fuse, which then cuts one of the repeaters which disconnects another Shelly. It’s painful, every time, though solely when the WiFi is cut. I wish it was within the firmware to force the Shelly to reconnect without going this detour. They simply don’t reconnect for days/weeks on their own.


    Obviously not everyone is on iPhones, but the HomeKit firmware is quite stable now and when connected over IP in browser it also shows you the above requested WiFi strength of the device.


    So whatever had been done right with the HomeKit firmware, the stock firmware might hopefully copy that. Apart of that I assume it’s absolutely vital to have a quality router and Internet provider crap is simply BS.


    Hope this helps a few and please notice anyone of matter that there will please be a different way to reconnect them to the WiFi when it’s back on. If they don’t do it automatically, there could be a different code for doing that with the physical Switch, switching it 8 times or so...


    PS: the static IP range of the shellies should not overlap with the DHCP range, as a disconnected Shelly may never get it back from a meanwhile connected device.

    Also, if you’re using a 5GHz network you MUST name it differently, because the shellies can only connect to the 2.4GHz and fail trying to connect to the wrong network.

    Edited 2 times, last by Party ().

  • I have the same issue with the latest firmware on shelly1.

    The device is powered on and the physical switch works, but it is not connected to the wifi network and I cannot control it remotely.