Shelly App loses conection with Shelly device

  • Hello.

    I'm the almost-happy owner of a Shelly 2.5 used on a roller shutter. I purchased it to be used mainly trough MQTT tough I've been able yet to use it like that, but I'll!!! my intention is to install it on all my 7 windows.

    So meanwhile I learn how to do the MQTT thing... I use the app on my IphoneX. the problem is that I get a lot of "disconnected" messages when Im using it, the app loses connection with the device. Wifi signal is good, (no more than 5 meters from router) latest firmware, latest app... but no solution.

    I've tried with andorid and works like a charm. but not from IOS.

    any clue?


    edit, same issue from my ipad

    Edited once, last by ifr ().

  • EDIT: Restored to factory default solved the issue

    I have pinpointed the issue. If I click on Enable MQTT on the shelly web interface, I lose the device on the Sehlly APP (but can still reach it on the web interface, so no conecction is really lost)

    Edited once, last by ifr ().

  • I am facing the exact same problem. I am running my Shellys (21 2.5) with the latest FirmWare und als have the newest App installed. But I still lose connections every day.

    Issue: I open the Shelly App and using it. After a few seconds most of the devices are not reachable. Even if I opened the same roller shutter seconds ago - it´s gone. Same problem with relays.

    ifr Are you using a MESH-WLAN?

    As you already mentioned before: the Shellys are not really offline or disconnected. No issues, if I try to connect via web interface.

  • Hi together,

    have you testet the app "ShellyHome" yet? ;)

  • Same issue here, I'm testing 3 modules, 1L, Dimmer2 and 2.5.

    All connected to a dedicated 2.4Ghz wi-fi network and only the 2.5 randomly loses connection to the shelly app, is about 2 meters away from the wifi repeater.

    Latest firmware and app.

    I can see that the 2.5 is always connected to the network even when the app is not connecting to it