Übersicht: Häufige Fehler und Probleme

    • Official Post

    In die Einsteigertipps und in den Erste Hilfe - Koffer habt Ihr ja bestimmt schon geschaut!? :/


    Haben die nicht weitergeholfen schaut Euch bitte die angepinnten Beiträge in den einzelnen Unterforen an. Dort findet Ihr weitere wichtige und hilfreiche Informationen.;)




    Nachfolgend eine Aufstellung häufiger Ursachen bei Problemen mit Shelly-Produkten.



    Die Liste wird stetig weitergepflegt, erhebt aber keinen Anspruch auf Vollständigkeit. ;)



    AktorProblem / Fehlerbild
    Abhilfe
    alleShelly kann nicht eingebunden werden in WLAN oder App, liefert keine Daten via MQTT
    Router inkompatibel?
    Shelly und (teilweise) nicht kompatible Netzwerkkomponenten
    Probleme Einbindung in die App SHELLY CLOUD
    Einsteigertipps B2 (für's WLAN)
    Fritzbox - empfohlene Einstellungen
    Shelly mögen weder versteckte SSID noch Sonderzeichen darin.
    Shelly in App trotz Positivmeldung im Raum nicht aufindbar
    eventuell ist der Shelly in HIDDEN DEVICE, kontrollieren und dort über "Bearbeiten" (Stift) die Zuordnung korrigieren
    Shelly wird eingeschaltet, knallt und Sicherung fällt, Schmorgeruch (ev. passiert das auch erst einige Tage nach Inbetriebnahme)
    Schaltspannung am SW liegt auf anderer Phase als die Versorgungsspannnung, somit 400V am Shelly --> Anschluß prüfen und korrigieren
    Probleme mit Glimmlampe im Schalter oder Taster
    Hier geht es zur Lösung
    Fehlermeldung:
    Bad default state, botton type combination
    Power on default mode anpassen
    Shelly soll sich selbst schalten (via Actions)
    Hierzu muß in den http-Requests die IP-Adresse durch "localhost" (ohne Anführungszeichen) ersetzt werden.
    alle mit Relaiskontakt
    Verbraucher bleiben an obwohl Shelly ausgeschaltet
    Ursache sind meist verklebte Relaiskontakte. Dieses Problem entsteht durch sehr hohe Einschaltströme.

    Abhilfe: Einschaltstrombegrenzer einbauen.

    Informativer Link dazu am Beispiel von LED-Leuchtmitteln
    230V-Shelly (ohne Leuchtmittel wie Bulb)
    kurze Zeit nach der Inbetriebnahme gibt es beim Einschalten einen Knall, mindestens 1 Sicherung fällt, ebenso falls vorhanden der FIIn annähernd 100% der Fälle handelt es sich um einen Anschlußfehler!
    Dieses Fehlerbild tritt auf, wenn für den SW eine andere Phase geschaltet wird als für die Spannungsversorgung an "L" genutzt. Somit liegen im Schaltmoment am Shelly 400V an.
    Shelly mit Schalter mit Kontrollleuche
    funktioniert nicht
    siehe dieser Lexikoneintrag
    Shelly schaltet kurz nach Einschalten die Leuchtmittel bzw. Verbraucher aus oder rebootet nach Einschalten
    Ursache sind of zu viele angeschaltete Leuchtmittel (Anzahl, nicht Leistung!).
    Abhilfe kann ein Einschaltstrombegrenzer schaffen.

    Ebenso kommt es ggf. zu Problemen beim Schalten induktiver Lasten, hier kann ein Ferritkern Abhilfe schaffen. Typisches Beispiel ist das Schalten von Motoren beim Shelly1PM

    Herstellerproduktempfehlung dazu.

    batteriebetriebene Shelly
    Gerät geht immer wieder offlineDas ist kein Fehler. Zur Schonung der Batterie gehen alle batteriebetriebenen Shelly in einen Sleepmode.
    Lexikoneintrag dazu.
    Eure Batterien halten nur sehr kurz durch und sind dann leer
    CR123 - Übersicht
    dient zur Orientierung aufgrund der Erfahrung anderer User.
    Shelly App
    Cloudprobleme oder Zugriff im WLAN
    Eine sehr gute Alternative ist die App ShellyPilot von AppPilot , die es aber bislang nur für Android gibt.
    Shelly1Ihr wollt Eure Garagentorsteuerung smart machen
    Shelly1 ist die 1. Wahl und im Unterforum finden sich schon zahlreiche Beiträge dazu.
    Shelly2.5Die Kalibrierung des Rollladenaktors macht Probleme
    Beachtet Mindestlast und das Thema Trennrelais, näheres in den Beiträgen des Unterforums

    Elektronische Rollläden (z.B. mit Funk) machen auch Problemem da die Mindestlast nicht erreicht wird.

    Am sichersten funktionieren ganz einfache Rollladenmotoren mit mech. Endeinstellung.
    schaltet wegen Übertemperatur ab!Leider ein häufiges Problem, dass eigentlich nur im Relais-Modus auftritt, insbesondere bei schlechter oder fehlender Belüftung/engem Einbau oder zu hoher Dauerlast. Die Werksangabe wird deutlich nicht erreicht.

    Der Rollladenmodus ist davon eigentlich nicht betroffen.

    Abhilfe schafft leider nur der Einsatz eines geeigneten anderen Shelly --> Shelly 1 (wenn man die Leistungsmessung nicht braucht) oder Shelly1PM.
    Leistungsdaten beachten!
    Shelly 3EM
    Messwerte nicht plausibel
    siehe dieser Thread
    Button1Einstellungen werden nicht gepeichertRemain Awake (battery) auf 5 einstelle, Einstellungen im USB-Betrieb machen
    DimmerEin- und Ausschalten funktioniert, dimmen nicht
    Anschlußfehler: L und O vertauscht --> Anschluß prüfen und korrigieren
    GeisterschaltungenPower On Default Modus von "An" auf "Aus"
    Dimmer2
    Error 1
    Keine Änderung der Betriebsspannung bei Betrieb ohne N
    eventuell Mindestlast prüfen

    Error 2
    Kalibrierung fehlgeschlagen,, da keine Leistungsänderung während der Kalibrierung
    neu kalibrieren
    Error 4
    Versorgungsspannungsproblem
    Door Window
    Öffnen und Schließen wird nicht zuverlässig detektiert
    Ausrichtung prüfen, Magnet und Sensor müssen gar nicht so dicht beieinander sitzen, wie viele annehmen. (Für funktionierende Montagen gibt es einige Bilder in Threads des Unterforums)

    Door Window Montagehinweis
    Gerät geht immer wieder offlineDas ist kein Fehler. Zur Schonung der Batterie gehen alle batteriebetriebenen Shelly in einen Sleepmode.
    unerwartetes Blinken, kein AP nach Reset
    Batterien prüfen / ersetzen
    FloodAlarm wird nicht übertragen bzw. im Log nicht angezeigtMeist wird beim Prüfen der Flood zu schnell wieder "trocken gelegt". Damit der Alarm im Log erscheint, muß der Flood bis zum Ende der Übertragung Alarm haben, d.h. im Wasser liegen
    H&TGerät geht immer wieder offline
    Das ist kein Fehler. Zur Schonung der Batterie gehen alle batteriebetriebenen Shelly in einen Sleepmode.
    Motion
    Gerät geht immer wieder offline
    Das ist kein Fehler. Auch der Motion geht in einen Teil-Sleepmode.
    Temp-AddonKeine Anzeige der Werte
    meist ein Verdrahtungsproblem --> prüfen und ggf. bessere Klemmen verwenden oder verlöten

    Firmware aktuell ? Auf sehr alter Firmware gab es das Addon noch nicht, folglich wird es nicht erkannt!
    wird anscheinend nicht erkannt
    Shelly mit dem Addon rebooten

    Das Addon darf nur im spannungslosen Zustand des Shelly gesteckt oder abgezogen werden,
    nicht erwartete/keine Anzeigen oder Funktion
    Achtung:
    Temp-Addon nur im spannungslosen Zustand des Shelly stecken oder abziehen!

    Reboot testen.
    • Official Post

    Danke Sebastian,


    hab's direkt aufgenommen. Hat uns ja lange beschäftigt, das Thema.^^

    • Official Post

    Danke SebMai .


    Hab's aufgenommen und noch bei der Gelegenheit Button1 aufgenommen. ;)

  • Eine Übersicht der Fehlercodes an dieser Stelle wäre schön. Mein Dimmer 2 zeigt "Error 2" in dem Web-UI an. Ich nehme an, dass er Probleme hat, da er noch nicht kalibriert ist, allerdings zeigte er an 3x 8W LED auch "overload" an und schaltete wieder ab. Danach habe ich das neueste Update 1.8.5 eingespielt und nun zeigt er "Error 2". Der http-Befehl kommt auch nicht an (soll von dem Dimmer an einen 1 PM gesendet werden), aber ich muss nochmals die Verkabelung kontrollieren, da ich heute morgen zu wenig Zeit hatte.


    Wäre halt schön, wenn man vor dem Ausbau gucken könnte, was "Error 2" heißt, damit man danach ggf. auch gleich gucken kann, falls etwas an der Verkabelung falsch ist.

  • Ich habe wohl leider 2x ins Klo gegriffen...

    Erster Shelly Dimmer 2 zeigt auch jetzt "Error 2" an, dimmt nicht korrekt (anderer Dimmer läuft mit identischen Leuchtmitteln) und wenn er mal einen Verbrauch anzeigt, ist dieser viel zu hoch. HTTP-Action wird nicht geschickt.


    Bei zweitem Shelly ist der eine "L" anscheinend nicht korrekt aufgelötet. An dem Anschluss habe ich die Taster dran, daher funktionierte der Serientaster nicht.


    Kamen beide aus einer Packung.

    • Official Post

    Stell man Screenshot der Fehlermeldung ein. Ich frag dann mal nach was der Code genau heißt.

    LG Michael


    Einsteigertipps / Tips for beginners

    Meine Shellys:

    In Betrieb: 3x Shelly Dimmer, 3x Shelly 1, 2x Shelly 1PM, 2x Shelly 2.5, 1x Shelly RGBW2, 1x Shelly 4Pro, 4x Shelly H&T, 1x Shelly Sense, 10x Shelly Plug S, 2x Shelly Plug, 3x Shelly Smoke V1, 1x Shelly EM, 1x Shelly Flood, 3x Shelly Duo GU10, 2x Shelly Vintage, Shelly Duo, 1x Shelly Eye, 3x Shelly Door/Window, Shelly Button, Shelly Button 1, Shelly 3EM, Shelly Gas

    Testboard mit Shelly Dimmer, Shelly Dimmer 2, Shelly 2.5, Shelly RGBW2, Shelly 1, Shelly 1Pm, Shelly i3, Shelly 2x Temp Add-On mit DHT22 und DS18B20, Shelly H&T, Shelly Door/Window 2


    Kein übergeordnete System. Nur App und WebUI mit Cloudverbindung.:)

  • Sehr wahrscheinlich ein Problem bei der Leistungsmessung. Wenn man schnell genug ist, sieht man den neuen Wert, bevor "Error 2" eingeblendet wird. Wert 100% ist niedriger als Wert 50% und das bei öfteren Probieren. Zudem sind 3x 7W verbaut, Nullleiter ist angeklemmt.

    Screenshot_20201028-212234_autoscaled.png

    Screenshot_20201028-212251_autoscaled.png

    Screenshot_20201028-212405_autoscaled.png

    • Official Post

    wieso ist der mit dem Error2 nicht kalibriert?

    LG Michael


    Einsteigertipps / Tips for beginners

    Meine Shellys:

    In Betrieb: 3x Shelly Dimmer, 3x Shelly 1, 2x Shelly 1PM, 2x Shelly 2.5, 1x Shelly RGBW2, 1x Shelly 4Pro, 4x Shelly H&T, 1x Shelly Sense, 10x Shelly Plug S, 2x Shelly Plug, 3x Shelly Smoke V1, 1x Shelly EM, 1x Shelly Flood, 3x Shelly Duo GU10, 2x Shelly Vintage, Shelly Duo, 1x Shelly Eye, 3x Shelly Door/Window, Shelly Button, Shelly Button 1, Shelly 3EM, Shelly Gas

    Testboard mit Shelly Dimmer, Shelly Dimmer 2, Shelly 2.5, Shelly RGBW2, Shelly 1, Shelly 1Pm, Shelly i3, Shelly 2x Temp Add-On mit DHT22 und DS18B20, Shelly H&T, Shelly Door/Window 2


    Kein übergeordnete System. Nur App und WebUI mit Cloudverbindung.:)

  • Eine Korrektur habe ich noch. Es ist der Shelly mit der schlechten Lötstelle, nicht der mit "Error 2", der die Befehle nicht per HTTP raus schickt.

    Ich habe 2 Dimmer 2 hinter 2 Serientastern. Jeweils 1 SW für die angeschlossenen Leuchten und 1 SW für die Actions, sprich 2 Shelly Dimmer 2 und 4 Kontakte.

  • Die Kalibrierung ist durchgelaufen und ich hatte die wieder gelöscht und nochmals durchlaufen lassen. Er zeigt mir auch "delete calibration" zur Auswahl an. Die Screenshots sind alle von dem selben Shelly Dimmer 2 ohne zwischendurch neu zu kalibrieren.


    Nachtrag: Der zweite Shelly führt die Action nicht aus, da die Schraubklemme keinen Kontakt zu Platine haben wird. Das ist die, die direkt neben dem L ist, der nicht korrekt funktioniert.


    Der "Error 2" des anderen Shelly bleibt auch nach mehrmaligem Kalibrieren, allerdings sind die Ergebnisse unterschiedlich.

    Edited once, last by Schubbie ().

    • Official Post

    ... Ich frag dann mal nach was der Code genau heißt.

    Wenn wir ein Erklärung zu den Codes bekommen, stelle ich sie oben in der Übersicht gerne ein.

    • Official Post

    Schubbie :


    Ich habe mal die Suche im Forum bemüht.


    Error2: Kalibrierung fehlgeschlagen


    Habe es oben schon ergänzt.

  • Da reichen meine Suchskills wohl nicht aus. Selbst wenn ich nur "Error" eingebe, bekomme ich nur diesen Thread. Allerdings hatte mir Google in diesem Forum einen englischen Beitrag für "Error 4" angezeigt.

    Der Fehler wurde allerdings bereits vor der Kalibrierung angezeigt. Wenn ich die Web-UI bei Kalibrierung geöffnet lasse, dann wird "Kalibrierung erfolgreich" nach Abschluss angezeigt, später kommt dann kurz die Meldung "Kalibrierung fehlgeschlagen". Die Meldung bleibt auch bei dem Shelly. Ich habe die beiden Dimmer an identischen Leuchtmitteln, jedoch 1x 2 flammig und 1x 3 flammig angeschlossen. Zuvor hatte ich die Lampendrähte vertauscht, sprich 2-/3-flammig jeweils am falschen Dimmer, der Fehler blieb nach Umklemmen bei dem selben Shelly.


    Dann werde ich die beiden wohl einsenden müssen. :( Einen wegen Klemmen, einen wegen fehlerhafter Leistungsmessung, wodurch anscheinend keine korrekte Kalibrierung möglich ist.

    • Official Post

    mal ein kleiner "Push" um das Thema vor Allem Neueinsteigern nochmal nahezulegen.


    Die Übersicht wurde gerade mal wieder erweitert und wird auch weiterhin (im Hintergrund) stetig aktualisiert und ergänzt. ;)

  • 66er

    Closed the thread.