NTP Server wird nicht benutzt (Gelöst)

  • Hallo Gemeinde.


    Mir ist etwas aufgefallen bei der Shelly Firmware.


    Beim Shelly2.5 und Dimmer (aktuelle FW)


    Wenn man seine Geräte in einen eigenen Netzwerk OHNE Internet Zugriff nutzen will haben oben genannte Geräte ein Problem mit (m)einen NTP Server.


    Die shelly bekommen keine Zeit und die Zeitpläne sind somit nutzlos.


    Alle Tasmota Geräte haben mit meinem NTP kein Problem.


    Mir kommt es so als ob die Individuellen Eingaben beim SNTP Server ignoriert werden.


    Ich muss erst das Gerät in das Wlan mit Internet hängen damit sich der shelly eine Zeit holt und kann es dann wieder in mein IoT wifi packen.


    Ich habe auch schon probiert alle 123 Anfragen auf 0.0.0.0 umzuleiten auch das geht nicht. Der schmutzige Trick funktioniert grundsätzlich bei andren Geräten wo man gar keine Möglichkeit hat etwas einzustellen, nur eben bei den Shellys nicht.


    Mein Router / Firewall ist ein Sophos UTM9.


    Hat da jemand eine Idee?

    oder gleich Tasmota drauf machen?

    Gruß


    Sebastian

  • Ich habe auch schon probiert alle 123 Anfragen auf 0.0.0.0 umzuleiten auch das geht nicht. Der schmutzige Trick funktioniert grundsätzlich bei andren Geräten wo man gar keine Möglichkeit hat etwas einzustellen, nur eben bei den Shellys nicht.

    Geht mir gleich. Mache ich auch so. Ich habe ein NAT für udp123 und udp53 um NTP und DNS umzuleiten. Der Bug ist bekannt und sollte soweit ich weiss mit 1.5.10 behoben worden sein. Vorausgesetzt, man hat Zeitzone und NTP Server auch korrekt eingestellt.

  • Hallo Bastik77,


    Erstmal noch nachträglich WILLKOMMEN IM FORUM


    Zu diesem Thema: Bitte erst suchen/informieren und dann "meckern".


    Wie Seven of Nine und vistalba schon geschrieben haben ist der Bug inzwischen behoben (seit der FW-Version 1.5.8). EIn interner ntp-Server funktioniert und kann benutzt werden wenn der Shelly keinen Zugang zum Internet hat.


    Es müssen nur die zwei folgenden Bedingungen erfüllt sein:

    1. Ein gültiger ntp-Server muß eingetragen sein
    2. Eine Zeitzone muß manuell eingetragen sein

    Ich schließe diesen Beitrag und setze ihn auf "Gelöst".

    Grüße Bernd


    Mein "Smarthome":

    FHEM als "Master"(Cloud-Free :))mit über 40 Shellys(1, 1PM, 2, 2.5, 4Pro, RGBW2, PlugS, alle mit Original-FW),13x Sonoff (Tasmota-FW),12x Blitzwolf/Gosund(Tasmota-FW), 80x One-Wire Temp-Sensoren(D1-Mini mit Tasmota-FW),51x Modbus(Hutschienenzähler),31x Intertechno 433MHz(Rolladen-Aktoren),12x FBDECT(8 Heizkörperthermostate, 4 Schaltsteckdosen),21x Homematic(16 Raumthermostate, 3 FB-Heizungsaktoren, 2 Repeater),etc. ...

    Neues von Print Worth 3D: ==> Marktplatz

  • Guzzi-Charlie

    Changed the title of the thread from “NTP Server wird nicht benutzt” to “NTP Server wird nicht benutzt (Gelöst)”.