Sind Shellys eine Bastellösung???

There are 22 replies in this Thread which was already clicked 887 times. The last Post () by Loetauge.

  • Hallo,


    ich dachte, nach dem JB Media Lightmanger und einigen anderen Smarthome Versuchen wie Homematic, mit den Shellys wäre etwas ausgereiftes am Markt.


    Ich bin kurz davor das Handtuch zu werfen.


    Hier mal die Fakten. Habe ca. vier "Shelly 1", einem "Shelly Dimmer²", einen "Shelly HT", zwei Shelly Plug S".


    Zwei der Shelly 1 arbeiten als Eltako Ersatz, davon einer in der Unterverteilung.


    Ein Shelly 1 mit dem Addon und Luftfeuchte/Temperaturfühler draussen am Haus in deinem 3D gedruckten Gehäuse mit stabiler Stromversorgung.


    Die zwei ShellyPlug S sind da um Regallichter zu schalten.


    Der Shelly HT hab ich nach innen verfrachtet da mich der "abundzu wachwerden" Status nicht zufriedenstellte. Hab den mit Teilen von Shellyparts.de fix an die Steckdose angesteckt.


    So weit erstmal gut. Ich muss noch sagen, unser Haus ist ein Bruchsteinhaus mit 60cm dicken Wänden. Da es Probleme mit der Verbindung immer wieder gab, hab ich mir eine neue Fritzbox 7590 AX mit Mesh Funktionalität geleistet. Dazu kamen noch 2 Powerline Sets (1220 mit 1260e) die im Mesh laufen.


    Habe die Shellys folgendermaßen eingerichtet:


    > Wlan Passwort geändert auf eins ohne Sonderzeichen


    > Allen Shellys eine feste IP ausserhalb des DHCP-Bereichs der Fritzbox gegeben


    > Eine Tabelle mit den IPs angelegt


    > Alle Shellys sind in der Cloud


    > Habe meine Räume angelegt


    Soweit ging das alles. Also das einrichten klappte, bei manchen Shellys zwar mit mehreren Anläufen, aber immerhin.

    Alles erfolgte über deren Webinterface.


    Trotzdem ist es bei mir extrem. Die Teile komnen und gehen. Sind da, dann aufeinmal wieder offline.


    Habe versucht ohne 5Ghz-Wlan auszukomnen, ohne Erfolg.

    Ich bekomme am Donnerstag noch eine Fritzbox 4040 die ich mit einem Ethernetkabel im EG platziere (die Meshmasterbox 7590 steht im OG) und mit Mesh das Wlan dort aufspanne.

    Ein Powerliner 1260e kommt noch in die Küche.


    Was seltsam ist, das alle anderen Geräte wie AlexShow, Handys und Co. stabil laufen. Auch mit der Fritz WLan App sind die Werte nie auf "Null".


    Wiegesagt, bin am verzweifeln. Was könnte das nur sein?

    Glaube schon fast an mysteriöse Erdstrahlen ;) .


    Da wir am Ortsrand wohnen, gibt es keine störenden Nachbar WLan Netze, habe das auch probiert, also die Fritzbox auf einen freien Kanal, aber bin wieder zurück auf dem Autokanal.


    Das Haus in dem wir zur Zeit wohnen ist eigentlich ein Test für mich. Wir sanieren ein zweites Haus. Der Umzug wird noch ca. 2 Jahre dauern. Ich möchte in dem neuen Haus etwas mehr Smarthome. Also wenigstens noch die Rolläden möchte ich fernbedienbar machen. Aber wenn das so wie zur Zeit läuft, bin ich am überlegen ob ich es lasse.


    Ich will kein HiEnd mit KNX oder so. Einfach nur mit einfachen Mitteln arbeiten.

    Wenn da maaaaal was nicht geht, kann ich mit leben. Aber so wie es zur Zeit läuft, das ist nix. X(


    Hoffe Ihr habt ein paar Tipps. Ich will eigentlich bei Shelly bleiben.


    Liebe Grüße

    Helmut

  • Sprich eigentlich hast du nur ein Problem?

    Sind die Shellies im eigenen Netz oder in der Cloud (App) nicht erreichbar, wofür auch das Internet stabil sein sollte?


    Mein Eindruck ist, dass die meisten Probleme, über die hier Themen erstellt werden, auf der Nutzung der Cloud beruhen.


    Vom Preis her merkt man bereits, dass es kein High-End ist, aber schlecht sind die dafür auch nicht.


    Für das neue Haus würde ich, wenn möglich, für alles Leitungen zentral in die Verteilung ziehen, so bleiben einem dann weitere Möglichkeiten offen und theoretisch brauchst du dann nur einen Accesspoint neben dieser Verteilung. Ist natürlich viel Kabelsalat, aber würde ich bauen / sanieren, dann würde ich es nach Möglichkeit so machen, um auf ein anderes System wechseln zu können.


    Falls deine Probleme nur in der Cloud auftreten, dann ist vielleicht eine eigene Hausautomation etwas für dich. Z.B. Home Assistant, Node Red, ioBroker ... was alles auf einem entsprechenden NAS oder Raspberry läuft.

  • PowerLine kann Probleme machen ;)

  • Wenn ich es richtig verstehe ist das alleinige Problem, dass Shellys des Öfteren Offline gehen? Wie du selbst sagtest ist das bei batteriebetriebenen Geräten logisch, aber es betrifft wohl auch die an die 230V angeschlossenen?


    Das kann ich bei mir ehrlich gesagt nicht bestätigen.

    Probleme hatte ich bei Bosch Smart Eyes Außenkameras, daher auch mit WLAN Repeater gearbeitet und seitdem Ruhe.

    Ich habe einen Shelly Plus 1PM in Betrieb, der sogar noch weiter weg und durch eine Außenwand (Garagenanbau) betrieben wird und Null Probleme macht. Von daher habe ich auch bei schlechtem WLAN eine stabile Verbindung.


    Hast du mal mit einem Smartphone getestet wie gut der WLAN Empfang an den entsprechenden Stellen ist?

  • Wollte schon meinen Elektriker fragen ob er mir einen Phasenkoppler in die Unterverteilung baut. Aber ich sag mal, ein Drittel der versprochenen Leistung geht durch die Dinger.


    Aber ich hoffe die Fritzbox 4040 bringt was. Meint Ihr mit Wlan Repeater zu arbeiten wäre die bessere und stabilere Lösung?


    LG

    Helmut

  • Einige Power-LAN Geräte haben anscheinend Probleme alle Nachrichten weiterzuleiten.


    Ich habe bei mir zu Hause Ubiquiti APs, aber alle an je einem LAN-Kabel.


    Tritt das Problem denn nur in der App auf oder auch Lokal, sprich Web-UI per IP nicht erreichbar?

  • der Begriff "Offline" ist ziemlich dehnbar..

    - sind sie im lokalen Netzwerk (WebUI) nicht erreichbar oder nur über die Shelly App?

    - wenn nur über die Shelly App: sind sie mit der Cloud verbunden oder nur lokal?

    - Haben die Shellies eine feste IP-Adresse oder bekommen sie ihre IP per DHC?


    Bei nur 4 Shellies ist das definitv kein Problem mit der Last und dem WLAN, ich würde entweder auf fehlerhafte Einstellungen im Shelly oder der FritzBox tippen oder auf Probleme mit der App, weil z.B. die Cloud daktiviert wurde.

    1x Shelly4ProPlus, 10x Shelly1, 7x Shelly 1PM, 2xShelly 1L, 9x Shelly 2.5, 3x Shelly2, 1x Shelly EM, 2x ShellyDimmer, 3x ShellyDimmer2, 1x Shelly 3EM, 1x Shelly4Pro, 1x Shelly Button1, 4x Shelly Duo, 1x, ShellyDuo G10, 3x ShellyVintage, 1x Shelly Bulb, 8x ShellyDuoG10RGB, 1x ShellyPlug, 2x ShellyRGBW2, 5x Shelly PlugS. 1x Shelly Sense, 3x Shelly i3, 1x Shelly Gas, 4x Shelly H&T, 1x Shelly Flood, 2x ShellyDoor&Window2, 3x TempAddon, 1x ShellyMotion

  • Für das neue Haus würde ich, wenn möglich, für alles Leitungen zentral in die Verteilung ziehen...


    Falls deine Probleme nur in der Cloud auftreten, dann ist vielleicht eine eigene Hausautomation etwas für dich. Z.B. Home Assistant, Node Red, ioBroker ... was alles auf einem entsprechenden NAS oder Raspberry läuft.


    Hallo,

    also das mit den Kabel ziehen wollte ich eigentlich vermeiden. Bei den dicken Bruchsteinwänden ist das eine Fummelei. Ich bin dabei den alten Putz abzuschlagen und dann werden die Fugen ausgebessert, danach kommet eine dicke Schicht Putz. Dann erst werden Schlitze gefräst, Kabel gezogen und dann kommt der finale Putz. Das muss ich so machen, da auf der blanken Wand keine Schlitze in die unebenen Steine gemacht werden können- Da bekommst Du keine Richtung rein. Für die LAN-Kabel würde es doch bedeuten in einem Mindestabstand von glaube ich 10cm weitere Schlitze zu schneiden. Die dürfen doch nicht mit den NYM-Leitungen in einen Schlitz.

    Das wäre bestimmt die beste Lösung. Aber auch einiges an Arbeit und Kosten für Kabel und Dosen. Crimpwerkzeug müsste ich mir besorgen. Naja...ich habe ja noch Zeit. Bin noch im Heizungsraum am arbeiten.


    So, weiter gehts. Also Home Assistant habe ich schon am laufen auf einem Raspberry mit LAN-Anschluß. Bevor ich mich da draufstürze sollte es erstmal normal laufen. Daher liegt der erst nur in Lauerstellung.

    Hier mla ein Screenshot von gesternmorgen. Als für einen Augenblick fast alle Shellys liefen.

    shelly-support.eu/index.php?attachment/26387/


    Ihr seht es ja. Da sind schon einige Geräte im Netzwerk. Die laufen auch soweit. Nur die Shellys sind sporadisch mal "dann weg".



    der Begriff "Offline" ist ziemlich dehnbar..

    - sind sie im lokalen Netzwerk (WebUI) nicht erreichbar oder nur über die Shelly App?

    - wenn nur über die Shelly App: sind sie mit der Cloud verbunden oder nur lokal?

    - Haben die Shellies eine feste IP-Adresse oder bekommen sie ihre IP per DHC?

    Tritt das Problem denn nur in der App auf oder auch Lokal, sprich Web-UI per IP nicht erreichbar?

    Also die Shellys sind tatsächlich nicht erreichbar. Die bekommen kein Wlan wie es aussieht. Ich versuche mal die Fritzbox AX umzupositionieren und mittels LAN-Verbindung die Fritzbox 4040 als Repeater im EG in Betreib zu nehmen. Hoffe es bringt was.

    Wie ist das mit den festen IPs. Ich habe die festejn IPs bei der Einrichtung im AP-Modus den Shellys verpasst. Soll man dann das gleiche nochmal im Frtiz-OS machen, oder ist das sogar schlecht. Hier mein Tabellchen damit ich die Übersicht nicht verliere. Die IPs sind alle ausserhalb des DHCP-Bereichs.

    Name




    Name Fritzbox




    IP




    Zimmer




    Stock




    Küchenlicht




    Shelly-Kuechenlicht




    192.168.178.100




    Küche




    EG




    Flurlicht




    Shelly-Flurlicht




    192.168.178.101




    Flur




    EG-OG




    Bettlicht




    Shelly-Bettlicht




    192.168.178.102




    Schlafzimmer




    EG




    Schlafzimmersensor




    Shelly-Schlafzimmersensor




    192.168.178.103




    Schlafzimmer




    EG




    Schlafzimmerlicht




    Shelly-Schlafzimmerlicht




    192.168.178.104




    Schlafzimmer




    EG




    Küche Regallicht




    Shelly-Regallicht-Kueche




    192.168.178.105




    Küche




    EG




    Schlafzimmer Steckdose




    Shelly-Schlafzimmer-Steckdose




    192.168.178.106




    Schlafzimmer




    EG




    Speicherlicht




    Shelly-Speicher




    192.168.178.107




    Speicher




    DG




    Werkstattlicht




    Shelly-Werkstatt




    192.168.178.108




    Werkstatt




    EG




    Aussensensor




    Shelly-Aussensensor




    192.168.178.109




    Hof




    EG





    Liebe Grüße und danke für die rege Anteilnahme

    Helmut

    Edited 2 times, last by neo-v: Vollzitate gekürzt. ().

  • Die IPs sind alle ausserhalb des DHCP-Bereichs.

    geht der Bereich bis 99? dann stelle den mal vorsorglich runter auf 90.. die ersten zwei IP-Adressen nach dem DHCP-Scope sind eigentlich für VPN-Verbindungen reserviert und kollidieren u.U. mit den Shellies.

    Ganz wichtig: bei Gateway ist bei den Shellies die IP der Fritzbox eingetragen, oder?


    Außerdem solltest du die hier genannten Einstellungen mal prüfen:

    1x Shelly4ProPlus, 10x Shelly1, 7x Shelly 1PM, 2xShelly 1L, 9x Shelly 2.5, 3x Shelly2, 1x Shelly EM, 2x ShellyDimmer, 3x ShellyDimmer2, 1x Shelly 3EM, 1x Shelly4Pro, 1x Shelly Button1, 4x Shelly Duo, 1x, ShellyDuo G10, 3x ShellyVintage, 1x Shelly Bulb, 8x ShellyDuoG10RGB, 1x ShellyPlug, 2x ShellyRGBW2, 5x Shelly PlugS. 1x Shelly Sense, 3x Shelly i3, 1x Shelly Gas, 4x Shelly H&T, 1x Shelly Flood, 2x ShellyDoor&Window2, 3x TempAddon, 1x ShellyMotion

    Edited once, last by Seven of Nine ().

  • Das mit den IPs ist Geschmackssache. Ich vergebe die ausschließlich per DHCP im Router, anderen schwören darauf diese fix in den Clients zu vergeben. Beides hat Vor- und Nachteile. Beides zu machen wäre nicht unmöglich, jedoch hast du dann die Nachteile beider Lösungen vereint, solltest dich also für eine Lösung entscheiden.

  • geht der Bereich bis 99? dann stelle den mal vorsorglich runter auf 90.. die ersten zwei IP-Adressen nach dem DHCP-Scope sind eigentlich für VPN-Verbindungen reserviert und kollidieren u.U. mit den Shellies.

    Das stimmt nur so halb, wie du schon schreibst belegt er für VPN nach dem DHCP Bereich, aber er belegt so viele Adressen wie du für VPN einrichtest.

    In meinem Fall im Moment die 113 frei, war mal belegt wurde gelöscht.


    pasted-from-clipboard.png

  • Nickelpiff wenn du in Rohr/Schlauch verlegst, zumindest für LAN in D Vorgeschrieben, darf es in einem Schlitz sein

  • Ihr seht es ja. Da sind schon einige Geräte im Netzwerk. Die laufen auch soweit. Nur die Shellys sind sporadisch mal "dann weg".

    Meisstens sind sie da, irren aber als Geister herum weil sie kein WLAN finden. Da gibts den Punkt "WiFi Client AP Roaming", wenn da ein Häkchenfeld ist bitte mal setzen.


    Für Smartphones gibts "WLAN-Analyzer" und die mal in die Nähe eines Shellies bringen zum zu sehen ob da überhaupt noch Signal ist (und wenn der Shelly dann hinter einem Schalter verbaut ist, nochmal ordentlich Abziehen)


    Cloud? Nie genutzt weil im Zweifel nicht debuggbar ("Geht nicht? Es klemmt irgendwo. Und wo? Kann man nicht ermitteln sondern nur Raten")


    Ich war lange ein Fan des Shelly CoLoT-Protokolls, weil es ein abgespeckter Bastard des RFC 7252 ist. Wenn man sich das CoAP-Protokoll in RFC 7252 genauer anschaut, vermisst man gewisse Features die man eigentlich erwartet hätte, wenn das Protokoll wirklich ernsthaft auf IoT ausgelegt wäre (zB. eine gewisse Leichtigkeit - kein Wunder, dass die Shellies da einen Fork hingelegt haben).


    Nach langem überlegen hab ich dann Colot überall rausgeschmissen und bin auf MQTT mit einem separaten Server umgestiegen wo die ganzen HA-Systeme nur noch Clients sind.


    Und siehe da: selbst vermeintlich störrische Shellies (wie DW, H&T, Motion) liefern sporadisch, aber regelmässig, am Mosquitto (MQTT Server) ihre Daten ab die dann irgendwann von der HA abgegriffen werden.


    Habe versucht ohne 5Ghz-Wlan auszukomnen, ohne Erfolg.

    Die Shellies (zumindest die "alten") können nur 2.4GHz, und das ist auch gut so - je höher die Frequenz desto schlechter verbreitet sich das Signal durch Mauern und um Mauern herum. Eigentlich müsste man die ins alte 400MHz-Band verbannen, aber das gibts ja nimmer für WLAN.

  • OK es läuft wohl wieder, dennoch eine Frage: nutzt du die Werkseingestellte Fritz!Box 4040... blabla Ssid?

    Nun die kann bei gleichzeitiger Nutzung durch weitere Nachbarnetzwerke zu Authentifizierungsprobleme führen, was zu Offline Meldungen führen kann. Wenn nicht, dann ist diese Ursache schon mal auszuschließen.

    MfG Lötauge.


    Zu jeder Lösung findet sich auch ein Problem! 8)


    4x Shelly 1 (auch im Button), 2x Shelly 2.5, 2x Shelly Dimmer, 1x Shelly Duo, 2x UNI, Shelly Plus 1, Shelly Plus 1PM, 3x OBI Steckdose mit Tasmota. Shelly App, IOBroker auf RaspberryPi4B(4GB), Fritz!Box7590, Fritz!Repeater2400, 2x Fritz!DECT301 HKR, ConbeeII Stick für Xiomi Sensoren

  • Ja nur eine SSID, die ist aber die Voreingestellte?

    MfG Lötauge.


    Zu jeder Lösung findet sich auch ein Problem! 8)


    4x Shelly 1 (auch im Button), 2x Shelly 2.5, 2x Shelly Dimmer, 1x Shelly Duo, 2x UNI, Shelly Plus 1, Shelly Plus 1PM, 3x OBI Steckdose mit Tasmota. Shelly App, IOBroker auf RaspberryPi4B(4GB), Fritz!Box7590, Fritz!Repeater2400, 2x Fritz!DECT301 HKR, ConbeeII Stick für Xiomi Sensoren