Shelly Cloud Beta

  • Hello,


    All feedback from the last couple of threads has been backlogged, will be discussed and evaluated for upcoming features.

    The App will no longer be tracked as different threads and this will be the main one for reporting bugs and questions.


    In this thread we will track the community bug reports for the second iteration of the Shelly Cloud App. New versions of the Test app and respectively a new thread will be opened weekly.


    Google Play link: https://shelly.cloud/app_download/?i=shelly_beta


    iOS TestFlight link: https://testflight.apple.com/join/z9fDOU9f


    :!: Reminder: Shelly Cloud Beta is a test app. Current version 0.2.5


    Change Log: 0.1.7 Pre-release -> 0.2.5 Pre-release


    Fixed Bugs:

    • Fixed inclusion and account add bugs, (still more remain).
    • Fixed thermostat ui bugs and some corner cases.
    • Adding last touches on NG devices, inclusion, integration with cloud, and ui differences.

    Please report any problems you come across but try not to have a lot of duplicates. Each week will gather reported bugs and fix as many as we can for the next release.

  • Hi alex@Allterco,

    now both apps (old and new) crash at startup on iOS, also delete and reinstall does not help.
    Now i can't controll my smarthome...
    PLEASE fix the startup crash for both apps also for the old one.

    And can you please make a topic with all backlogged things? That we can see what Bugs or features you have written down and what is fixed/planned?
    That would help betatesters a lot.

    Thanks

  • Did you check with https://testhome.shelly.cloud/
    It's web based version which should work until iOS developers will fix it.

  • Greetings,


    The backlog will be posted shortly.


    Concerning the iOS app crushing, it seems some data has been corruped by the beta app. It would be of much help if we knew what features you have been using, for instance scenes, thermostats or moving things around in a list?


    In order for us to clear the corrupted data. You can use the web version (testhome.shelly.cloud) to enable the temporary support entry to your account. And PM me or Dimitar Stanishev the email associated with the account.


    Thanks for your support.

  • Hi alex@Allterco and Dimitar(Shelly team),

    i have pm you Alex.

    BTW, the old and new web versions are working:

    my.shelly.cloud

    testhome.shelly.cloud
    "only" both apps crashing on startup for iOS.


    I have "tried" to edite a lot... :)

    I have tried to move scence on the main page and in the Room named "Bad". Maybe this has broke some things.

    I have edited scenes in the "Bad" Room, becasue of the missing "white" slider in the old app for scenes.

    I have also tried to move Rooms.


    i hope you can fix all corrupted data. Also i hope that fix the problem that the old is also crashing on startup.

    Thanks a lot
    Johannes

  • In the future, please also create the possibility of grouping other devices such as lights, relays and roller blinds.

    I miss the DW2s, the Motion, the Button1 or the i3 in a group.

    3EM is also missing from the selection as a relay

    Please also provide the group symbols for lights with a light bulb symbol (similar to RGBW2)

  • Updated the interface to 0.2.6 today, mostly for iOS tests and small fixes.

    We have managed to pinpoint 2 problems with the data storage on iOS and are working to solve them, without loosing any data.


    If any of you still has an unresponsive ios app,

    pls pm me your account credentials or use the web version of the app to enable the temporary support access.


    Will be updateing thebinterface again tomorrow, with hopfully the final fixes for iOS.

  • @iceman

    you only have to delete the scenes that were edited via the beta app. i also left two old ones. maybe you see like in my screenshot that there is "undefined" for the days.


    @alex@Allterco

    I am very happy... that with me the app now runs again. In the BETA app the switches for my blinds do not work. Is this known?

  • Hello alex@Allterco.

    I reported in the very first beta version that devices with MQTT enabled were showing as offline in the new app, while they appear unreliably online and offline in the old app, when on the same LAN network.

    This is still the case for the current version. In this state, the Shelly app is completely useless for me. Is there a plan to make them appear as they used to, but more reliably ?

    Thank you for your work.

  • I think the font size should be a bit smaller, or perhaps it needs a line break!?

    In the old version I can read if it's the right or left side, here I can only read "roller shutter l..."


    And I don't know if it's only in android dark mode, but the arrows on the buttons are too dark.


    20210909_074915.jpg

  • As i can see on beta version the Shelly 2.5 gives the Tension values to appearing on widgets

    pasted-from-clipboard.png


    But on the Shelly 1PM only appears the consumption.

    pasted-from-clipboard.png


    Why we can't also see the Tension on the Shelly 1PM devices?



    There's a bug on my Shelly EM, the total consumption doens't appears on the room, top left and isn't exclued...


    pasted-from-clipboard.png

    Edited once, last by L.Sousa ().

  • Hello, I have the beta version installed (iOS). All devices offline. In the original App all devices on work! What can I do? Thanks!